INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Falscher Analogwert bei Wechsel von PCI-6229 auf USB-6343



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

05.03.2021, 12:39 (Dieser Beitrag wurde zuletzt bearbeitet: 05.03.2021 12:44 von jg.)
Beitrag #11

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.850
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: Falscher Analogwert bei Wechsel von PCI-6229 auf USB-6343
(05.03.2021 11:15 )X19CrEaTiVe68X schrieb:  Hallo Martin, diese Problematik ist mir geläufig. Dafür sind meine differentiellen Analogeingänge nur jeder 2. genutzt und die freien alle gegrounded.
Das würde aber bedeuten, das die USB-6343 anders, bzw. empfindlicher auf das Problem reagiert, als die PCI-6229.
Im NI Example 1 Analogeingang funktioniert die Messung auch, kann diese ggf. mal auf 4 Eingänge aufbohren.

Gruß
Andreas
Hallo Andreas,

dass du verschieden Eingänge auf Masse gezogen hast, spielt meiner Meinung nach keine Rolle, da diese nicht Teil deines AI-Task sind. Der Multiplexer der Karte springt nur durch die Kanäle des AI-Tasks.

s. auch hier:
https://knowledge.ni.com/KnowledgeArticl...AG&l=de-DE

Du könntest mal mit DAQmx Timing Properties rumspielen, immerhin kann deine neue Karte die doppelte AI-Erfassungsrate.

Gruß, Jens

(05.03.2021 12:28 )GerdW schrieb:  Und warum sind es 17 DIFF-Kanäle? Bei einem Gerät, welches nur 16 DIFF-Kanäle anbietet??? Hmm
@GerdW: Ich glaube, das hast du falsch verstanden, s. den zweiten Screenshot von Andreas. Die Pins AI0-AI15, sowie AI16&AI24 sind für DIFF-Messungen reserviert (also 9Stück).

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
09.03.2021, 14:32 (Dieser Beitrag wurde zuletzt bearbeitet: 09.03.2021 14:46 von X19CrEaTiVe68X.)
Beitrag #12

X19CrEaTiVe68X Offline
LVF-Neueinsteiger


Beiträge: 8
Registriert seit: Mar 2021

2018
1995
kA



RE: Falscher Analogwert bei Wechsel von PCI-6229 auf USB-6343
Hallo,
da bin ich wieder ... srry die Arbeit ;-)

(05.03.2021 12:28 )GerdW schrieb:  Hallo Andreas,

Zitat:0 - 16 sind DIFF
17 - 20 sind RSE
Und wie sind die DIFF-Kanäle beschaltet?
Und warum sind es 17 DIFF-Kanäle? Bei einem Gerät, welches nur 16 DIFF-Kanäle anbietet??? Hmm
Du hast dir das Manual durchgelesen, wo die Pin-Belegung je nach DIFF/NRSE/RSE-Modus beschrieben wird (Seite 4-5 und folgende)?
Was genau soll man in dem winzigen Bild zur Kanalbelegung erkennen?

Die AI 0, 2, 4, 6, 8, 10, 12, 14, 16 sind DIFF genutzt, die AI dazwischen liegen auf Ground.
Die AI 17 - 20 sind RSE genutzt.

Der Plan war auf dem winzigen Bild die Kanalbelegung zu erkennen.
Srry hatte nicht an Handynutzer gedacht.

Gruß
Andreas


(05.03.2021 11:21 )jg schrieb:  Hallo,

es gibt doch einige Unterschiede:

6229:
M-Serienkarte
PCI-Bus
Anschluss: 2x 68poliger VHDCI -> und wie habt ihr dann eure Signale angeschlossen?

6343:
X-Serienkarte
USB-Bus (wie sieht es mit der Masse aus?)
Anschluss: Die Karte gibt es in den Varianten Screwterminal und BNC-Anschluss, was setzt ihr ein? Wie habt ihr jetzt eure Signale angeschlossen?

Die Hinweise von Martin und RMR finde ich gut, aber vor allem bei RMRs Hinweis können wir nicht sagen, ob er zutrifft oder nicht, dein erster Screenshot-Ausschnitt enthält nicht alle Infos.

Gruß, Jens

Hallo Jens,
okay da gibt es Unterschiede.
Bei der PCI gehe ich von den VHDCI auf 2x D-Sub50 und von dort auf die Messhardware.

Bei der USB ist es die Screw Variante, an denen 2x D-Sub50 via geschirmte Kabel angeschlossen sind.
Innerhalb des Anschlussbereiches liegen die Ader ungeschirmt, da habe ich gegenüber der PCI nen Nachteil.

Gruß
Andreas
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
09.03.2021, 14:53
Beitrag #13

X19CrEaTiVe68X Offline
LVF-Neueinsteiger


Beiträge: 8
Registriert seit: Mar 2021

2018
1995
kA



RE: Falscher Analogwert bei Wechsel von PCI-6229 auf USB-6343
(05.03.2021 12:39 )jg schrieb:  
(05.03.2021 11:15 )X19CrEaTiVe68X schrieb:  Hallo Martin, diese Problematik ist mir geläufig. Dafür sind meine differentiellen Analogeingänge nur jeder 2. genutzt und die freien alle gegrounded.
Das würde aber bedeuten, das die USB-6343 anders, bzw. empfindlicher auf das Problem reagiert, als die PCI-6229.
Im NI Example 1 Analogeingang funktioniert die Messung auch, kann diese ggf. mal auf 4 Eingänge aufbohren.

Gruß
Andreas
Hallo Andreas,

dass du verschieden Eingänge auf Masse gezogen hast, spielt meiner Meinung nach keine Rolle, da diese nicht Teil deines AI-Task sind. Der Multiplexer der Karte springt nur durch die Kanäle des AI-Tasks.

s. auch hier:
https://knowledge.ni.com/KnowledgeArticl...AG&l=de-DE

Du könntest mal mit DAQmx Timing Properties rumspielen, immerhin kann deine neue Karte die doppelte AI-Erfassungsrate.

Gruß, Jens

Hallo Jens,
das kannte ich so noch nicht.
Ich bin mir fast sicher, dass das Grounding ne NI Empfehlung war, wenn auch vielleicht ein paar Jährchen her ;-)

Werde mal ein Testprogramm zusammentackern, der auf alle AIs zugreift und dann auch mal die Sache mit Dummy AIs checken.

Die Erfassungsrate habe ich schon in alle Richtungen vergewaltigt, da passiert nichts.

Gruß
Andreas
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
15.03.2021, 15:18
Beitrag #14

X19CrEaTiVe68X Offline
LVF-Neueinsteiger


Beiträge: 8
Registriert seit: Mar 2021

2018
1995
kA



RE: Falscher Analogwert bei Wechsel von PCI-6229 auf USB-6343
Hallo, nochmal ein abschliessendes Update.

Alle Versuche haben keine Besserung gebracht.
Erst nachdem ich die 4 RSE Kanäle auch auf DIFF umgestellt habe, war die Messung in Ordnung.
In diesem Fall hatte ich entsprechende Eingänge zur Verfügung, um das zu bewerkstelligen.
Irgendwie passte der Karte die Mischung RSE und DIFF nicht.
Auch die neue Programmierung hat nur so lange funktioniert, bis ich die RSE ins Spiel gebracht habe.

Ganz glücklich macht mich die Lösungt nicht, auch wenn es in diesem Fall funktioniert.
Irgendwann kommt der Punkt, wo die Anzahl der analogen nicht ausreicht um alle analogen im DIFF Mode zu betreiben.

Besten Dank für eure Hilfe.
Gruß
Andreas
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  Spannungsbereich von Messkarte NI-6229 Christoph1993 1 1.958 03.07.2019 09:37
Letzter Beitrag: jg
  PWM Timing Problem bei Wechsel von DAQmx 9.6.1 auf 9.8 dali4u 2 3.364 17.07.2014 13:43
Letzter Beitrag: dali4u
  PCI 6229 Ausgänge nicht auf 0V machfax 4 4.007 22.11.2013 09:54
Letzter Beitrag: machfax
  Wechsel von USB Karte/ Physikalischen Kanal automatisch flippi2187 4 3.324 02.09.2013 11:44
Letzter Beitrag: flippi2187
  Einzelner Analogwert erfassen durch ext. Triggerimpuls Nullstrom 6 4.389 12.09.2012 21:26
Letzter Beitrag: Nullstrom
  PXI 6229 Temperaturerfassung Börny 7 6.075 31.08.2011 10:51
Letzter Beitrag: Mingo

Gehe zu: