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2 * General

Copyright © 2005 by WAGO Kontakttechnik GmbH
All rights reserved.

WAGO Kontakttechnik GmbH
Hansastralie 27
D-32423 Minden

Phone: +49 (0) 571/8 87 -0
Fax: +49 (0) 571/8 87 — 1 69
E-Mail: info@wago.com

Web:  http://www.wago.com

Technical Support
Phone: +49 (0) 571/8 87 -5 55
Fax: +49 (0) 571/8 87 — 85 55

E-Mail: support@wago.com

Every conceivable measure has been taken to ensure the correctness and com-
pleteness of this documentation. However, as errors can never be fully ex-
cluded we would appreciate any information or ideas at any time.

We wish to point out that the software and hardware terms as well as the
trademarks of companies used and/or mentioned in the present manual are
generally trademark or patent protected.

® Application note
WAGD A201601


mailto:info@wago.com
http://www.wago.com/
mailto:support@wago.com

Table of Contents 3

TABLE OF CONTENTS

1 Important COMMENLS ......cccverererrcrsrnecsssrscssasscsasssssnnes .4
1.1 Legal principles......ccceeciieriieiieiie ettt et 4
1.1.1 (070700 0 121 | SRR 4
1.1.2 Personnel qualification ............cceeeiiiieiiieeiiie e 4
1.1.3 INEENAEA USC...eoeiiieiiieeciee e e e 4
1.2 Range of Validity.......cceevuieriiiiieiiiciieee ettt e 5
2 DeSCIIPLiON...cuueiicsseeeissnricssnnessssncssssnesssnessssessasssssssnosssssssssssossssssssssssssssssssnss 6
3 Reference Material .......eoeeeiiieeiiseeiisnnenssneissnnecssnnecsssnecsssnscssseecssssecssans 7
3.1 Procedure 1: Configuring the OPC Server ..........cccoevvvvvieniiecieenieeieeeen, 7
3.2 Procedure 2: Writing a client application in LabVIEW. ........................... 16
Application note m=u®

A201601



4. Important comments

1 Important comments

To ensure fast installation and start-up of the units described in this manual,
we strongly recommend that the following information and explanation is
carefully read and adhered to.

1.1 Legal principles

111  Copyright

This manual is copyrighted, together with all figures and illustrations con-
tained therein. Any use of this manual which infringes the copyright provi-
sions stipulated herein, is not permitted. Reproduction, translation and elec-
tronic and photo-technical archiving and amendments require the written con-
sent of WAGO Kontakttechnik GmbH. Non-observance will entail the right of
claims for damages.

1.1.2 Personnel qualification

The use of the product detailed in this manual is exclusively geared to special-
ists having qualifications in PLC programming, electrical specialists or per-
sons instructed by electrical specialists who are also familiar with the valid
standards. WAGO Kontakttechnik GmbH declines all liability resulting from
improper action and damage to WAGO products and third party products due
to non-observance of the information contained in this manual.

11.3 Intended use

For each individual application, the components supplied are to work with a
dedicated hardware and software configuration. Modifications are only admit-
ted within the framework of the possibilities documented in the manuals. All
other changes to the hardware and/or software and the non-conforming use of
the components entail the exclusion of liability on part of WAGO Kon-
takttechnik GmbH.

Please direct any requirements pertaining to a modified and/or new hardware
or software configuration directly to WAGO Kontakttechnik GmbH.
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Important comments 5

1.2 Range of validity

This application note is based on the stated hardware and software of the spe-
cific manufacturer as well as the correspondent documentation. This applica-
tion note is therefore only valid for the described installation.

New hardware and software versions may need to be handled differently.
Please note the detailed description in the specific manuals.
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6 Description

2 Description

The purpose of this document is to provide step-by-step procedures for con-
figuring National Instruments’ LabVIEW for communications with WAGO’s
Ethernet TCP/IP I/O. The procedures that follow illustrate how to configure
National Instruments’ Lookout Protocol Drivers OPC Server to handle the
Modbus/TCP communication services, and how to attach data made available
by the OPC Server to discrete controls and indicators in a sample LabVIEW
application.

The procedures in this document have been tested with (but are not limited to)
the following hardware/software configuration:

¢ Intel Pentium III based PC running Windows NT 4.0 Operating System
with Service Pack 6

e National Instruments LabVIEW 6i

e National Instruments Lookout Protocol Drivers OPC Server, Version 4.0
e 3 Com Ethernet Network Interface Card

e WAGO 750-342 Ethernet TCP/IP Buscoupler

e WAGO 750-400 2pt. Digital Input Module, 24VDC

e WAGO 750-501 2pt. Digital Output Module, 24VDC

e CAT-5 Crossover Cable for Ethernet Communications

For other details about WAGO I/O please refer to the WAGO Users Manuals.

The User Manuals can be downloaded from the web site www.wago.com
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3 Reference Material

3.1 Procedure 1: Configuring the OPC Server

1) Begin by running the OPC Server configurator Lookout Protocol Drivers
OPC Server 4.0.
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Figure 1: Running the OPC Server Configurator.
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8 Reference Material

2) Select File -> New... from the top menu.

Figure 2: Start a New Configuration.

3) Select Object -> Create... from the top menu.

Figure 3: Create a new database.
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4) Select Modbus as the Object Class and click Ok.

Select object clazs: E |
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Figure 4: Select Modbus as the Object Class.
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10 - Reference Material

5) In the Create Modbus Secondary window, select Modbus Ethernet for the
mode, enter the node’s IP Address, and give the connection an appropriate
name (e.g. EthernetConnection). Click Ok when finished.
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Figure 5: Defining the ethernet connection.

6) Select Object -> Edit Database... from the top menu.

Description

Figure 6: Edit the database.
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Reference Material 11

7) In the Edit Object Database window, select the database created in steps 3
through 5 (EthernetConnection), and click Ok.

Edit object database: |

Ok I Cancel

Figure 7: Select database to edit.
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12 Reference Material

8) Configure the I/O points for the application by entering in the Member (I/O
Address) and Description for each point of I/O. Click Save after each Mem-
ber and Description entry. The following table shows the Members and De-

scriptions used in this example:

Member Description

000001 WAGO Node 1 Output 1

000002 WAGO Node 1 Output 2

100001 WAGO Node 1 Input 1

100002 WAGO Node 1 Input 2

EthernetConnection database |
—Alarm conditions

Gru:uup:l j

Configured pointz: M ative members:

1000071 -185000
10007-19359 [ Generate logical alamm

1-9333 -
300001-365000 Pririy: |
30001-33339
400001.1-46500016 =]

lagical read-only

Aliaz [ophionall; bl embier:
| 100001

Drescription

[\w/AGD Mode 1 Input 1

On | Off;

[ Invert logical signal

Save I [Ielete Select object. . Irpart.... E=port... [ uiit

Figure 8: Editing the database.
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Reference Material *13

9) Click Quit when all Members and Descriptions have been entered.

EthernetConnection databaze |
Configured points: I ative members: — Alarm canditians
00000 000001 065000 f’ Group| =]
100001 -165000
100001 10001-19339 [T Generate logical alam
100002 1-9339 .
300001365000 Prioriy: |

30001-39935
400001.7-465000.16 ;I
logical readAwrite

Aliaz [optionall: hd embier;
| 000002

Dezcription

[twAG0 Mode 1 Output 2

On: | off

[ Irwert logical signal

| &te I Delete Select object... [mpart... Export... [ Liit

Figure 9: Completing the database.

10) Select File -> Save As... from the top menu.

B Lookou! Protocol Diivers DPC Server - [ustithed)
HEl Ofvect Dpliore Mo Help
Hewe Ckl Foup Pr. Tag Description
Open Chls0l
Ll
Save
Egit

Figure 10: Saving the Process File.
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14 - Reference Material

11) Type in an appropriate filename (e.g.

WAGO_ModbusTCP_Connection), and click Save.

Save Process File As.

Save in; I ] lkoposry

I 6 =1} )]

HE|

| sinecl?
File name: IW.-’-‘-.G 0_ModbusT CP_Connection Save I
5 ave az lype: IF'rDI:ESS Files[* lpd) j Cancel |

7 | Bratest He Friamm et with peun secaunt rame /A asswend

Figure 11: Saving the Process File (continued).

12) Select File -> Exit from the top menu.

ELuokuut Protocol Drivers OPC S5erver - wago_modbustcp_connection. lpd

File Object Options  Alams  Help

Mew... Ctrl+M I:up Pr. Tag Description |
Open... Cirl+0

LCloze

Saye

Save Az

Figure 12: Exit the OPC Server Setup Tool.
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Reference Material 15

13) When prompted to make the current process file the startup file, click Yes.
The application will exit, and the OPC Server configuration will be completed.

Lookout Protocol Dnvers OPC Server |

@ tdake the current process file the startup file?
] Mo | Ear‘u:ell

Figure 13: Make the current process file the startup file.
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16 Reference Material

3.2 Procedure 2: Writing a client application in LabVIEW.

1) Begin by running the LabVIEW 6i development software.
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Figure 14: Starting LabVIEW.
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2) Select New VL.

i LabVIEW M= e |
New V1 |~ |
NATIONAL INSTRUMENTS™
Open il | =
DAL Solutions

~Quick Tip:

To pauge the execution of a %l at any subyl, node, or wire, select the
Breakpoint tool from the Toolz palette and click the object. Then mn the .

Search Examples

LabwIEw Tutorial

[ et I Euit

[ Do not show this window when launching

Figure 15: Starting a New V1.
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18 Reference Material

=l SampleApplication. vi [_ O] =]

File

3) Create an application similar to the sample shown in the following figures.
Reference LabVIEW?’s Help menu for assistance with creating this applica-
tion. Do not be concerned with associating the four onscreen indicators with
real world I/O at this time. This operation is described in upcoming steps.

Edit Operate Toolz Browse “Window Help

=% I{Eﬂ @ IE | 13pt Application Font |« || ;mvl

EX
= |
]

Start/Stop |0 Scan

lrput 1 Input 2 Output 1 Output 2

3 ® o °® o

File

=l SampleApplication.vi Diagram

Edit Operate Toolz Browse “Window Help ﬂ

D [@] @[n][2] [oal@]or [ 130t sppication Fort |~ ][] [Ta ~][#5~]

Start/Stop |0 Scan

Figure 16: Sample Application.
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Reference Material 19

4) Now we will attach each onscreen indicator to a real world I/O address.
Start by right clicking on the Input 1 indicator. Select Data Operations ->
DataSocket Connection... from the menus.

> Sampled pplication. vi
Ele Edt Orersie ook Soses ‘Window Help

| (@] @[] [Tt AesteainFon_~ [t ][5 -]
Iritasrest

Exploins ‘o Start/Stop 10 Scan

Hebwork.
Heighborhood

Ingrit 1 Input 2
a

' Wikl |b=m

Fired Terrringl

Charge 1o Inchcator

Decstaiphions and Tip...

Comste:
2 Samplespplication vi Disgram ____|Jpereen .

Fi= Ect Orevsie Jook Brosse Window Heip

| _Data Dpesabors _+ |
of S [Pl [ st

Aicrobat Mecharical Action

Reader 4.0
ShartSiop 10 Scan Copy Dala
E & i i F

inged 7] Changs Valus bo Trus

b
Citix Program
Hesghbaihoad

st | B Microsoitwond - M_Apa.. | LasviEw | BB samsintppication vi Liag:. |5 5 ampletpglic stion. vi SN 1:56aM

Figure 17: Making a DataSocket Connection.

Application note

A201601 IVAEU



20 Reference Material

5) Click on Browse... to locate a DataSocket Connection.

Il DataSocket Connection |

Connect To:

I Browse...

Connection Type
" Publizh [+ Enabled

# Subscribe Only enabled connections publish and/or
& Publish and Subscribe subscribe data when % rung.

Altach Remove | Cancel |

Figure 18: Browsing for an Item.

6) Select Browse Measurement data... from the menu.

| 1> Samplefpplication. i M (=1E3
Fie £ Opeiats JTook: Biowss Windew Help

& [@] @[] [ 130 dppheation Font— |+ |[S= ]S =1[]
Micrascit

wiond Stat/Siog 10 Scan

Input 1 Input 2 Outped 1 Qustprt 2
O - -

B DataSocke! Conmeclion

Bocasien Mg aaian! dals

Browse File system...
7 Enabled ity

Onlyersbledcorrmel___
subscibe dats when 'Vl uns. 1

Mcrobal
Reader 4.0

é‘.@

Aulndesk Yolo
Yigws Expess

Civis: Program

o Shant | B Microsclt word - HI_pphl ]ILaW‘IE‘.\I‘ [B) Samgietppicationvi Diags. | [3] Sampletpphcation vi N M

Figure 19: Browsing for an Item (continued).
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Reference Material 21

7) Expand the directory tree structure as shown, and select item 100001 from
the item list. Click Ok to continue.

Browsze for Item |

EI--- iy Computer - | ok I

-EL Mational Insturments OPCD e
EI Mational Instruments. OPCLookoutDrivers Cancel
=27 Lookout Protocol Drivers
E1-{2 EthermetConnection
a8 000001
w8 000002
R 100001
w87 100002

U8 100n1.199a9 hl
| ri’ b
Browsze hu:ust:l RBefresh |

URL: IDDDZ.-".-"|DDH||"IDSL-"N ational Instrumentz. OPCLookoutDrivers E themetCo

Figure 20: Browsing for an Item (continued).

8) Click on Attach to complete the operation.

ii>! DataSocket Connection

Connect To:
Ippc:.f’flugalhnstle atig:uplal [nstruments.DPELDDknutD rivers! Browsze. . |
Connection Type
© Publish [¥ Enabled
# Subscribe Only enabled connections publish and/or
# Publish and Subscribe subzcribe data when Yl mins.

Attach Remove Cancel |

Figure 21: Completing the Attachment.

9) Repeat steps 4 thru 8 to attach Input 2, Output 1, and Output 2 to real
world I/O addresses. Note that when attaching the Outputs, it is necessary to
select Publish as the connection type.
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22 Reference Material

10) When completed, the application is ready to run. Click on the white arrow
icon to run, and click on the Start/Stop I/O Scan switch to begin execution. If
successful, the onscreen indicators will illuminate as voltage is applied to the
inputs and the logic solves true for the outputs.

EE Sampledpplication.vi =] E3
File Edit Operate Toolz Browse ‘Window Help
= @@ [ 13pt Application Fort [~ ][ 2o+ |[Ga < |[#5+]
Fun
Start/Stop |0 Scan
lput 1 Input 2 COutput 1 Output 2
; ‘\ o @ I
Kl I DY

Figure 22: Starting the Sample Application.

= ~
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H:?m::l PF::TE::' > SampleApplication. vi
Fie £ Opeials Took Hiowss Windew Help
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Microscit
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Stat/Siog 10 Scan
Inpue 1 Input 2

-

Fir Edt Opersle Took Browse Window Help

LEDEEE

F. st/ Slop 10 Scan

ol 5ot | B Microsolt wiond - M_spp | Labhigws

|E5-wppieuimuiniq I‘iaﬂdnﬂwﬁc!m'ﬁ o Lockout Protocal Diivers QN.E 1210 P

Figure 23: The Running Sample Application.
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