INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Dieses Thema hat akzeptierte Lösungen:

OPC UA Connect.vi sehr langsam



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

17.05.2021, 07:20
Beitrag #1

davtrs Offline
LVF-Neueinsteiger


Beiträge: 4
Registriert seit: May 2021

2017
-
DE



OPC UA Connect.vi sehr langsam
Hallo zusammen,

ich habe ein Problem mit der Verbindung zu einem lokalen TwinCAT OPC UA Server.

In einer unserer Anlagen sind zwei identische Industrierechner verbaut (Gleiche Specs).
Beide Computer laufen mit Windows 7 und verwenden LabVIEW 2017 und das OPC UA Toolkit (2017).

Mein Problem besteht darin, dass die Verbindung zum lokalen OPC UA Server zwar auf beiden Rechnern funktioniert, jedoch benötigt der eine Rechner ca. 1 s und der andere Rechner ca. 10 s mit dem NI OPCUA (2017) Client.lvlib:Connect.vi. (siehe Screenshots)
Hatte jemand schon mal ein ähnliches Problem oder könnte wissen, woran es liegt?

Gruß und vielen Dank im Voraus.

David


Angehängte Datei(en) Thumbnail(s)
       
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
17.05.2021, 09:55 (Dieser Beitrag wurde zuletzt bearbeitet: 17.05.2021 09:56 von GerdW.)
Beitrag #2

GerdW Offline
______________
LVF-Team

Beiträge: 16.988
Registriert seit: May 2009

11SP1, 17SP1 (ab und zu 20)
1995
DE_EN

10×××
Deutschland
RE: OPC UA Connect.vi sehr langsam
Hallo David,

herzlich willkommen im LabVIEW-Forum!

Erstmal nur eine Anmerkung zur Begrüßung: Crossposts in anderen Foren bitte immer selbst per Link anzeigen!

Was ist so schlimm daran, wenn das (einmalige) Öffnen der Verbindung bei einer PLC etwas länger dauert als bei der anderen?

Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
17.05.2021, 15:19
Beitrag #3

davtrs Offline
LVF-Neueinsteiger


Beiträge: 4
Registriert seit: May 2021

2017
-
DE



RE: OPC UA Connect.vi sehr langsam
Hallo GerdW,

vielen Dank und ich werde deine Anmerkung für die Zukunft beachten.

Eigentlich ist daran nichts schlimm, nur verwenden wir in diesem Projekt das Messenger-Library-Toolkit. Jede Verbindung zum OPC UA-Server wird mit Hilfe eines gestarteten Aktors realisiert.
Durch die lange Zeit, die das Connect.vi zum Verbinden braucht, führt dazu, dass bei dem einen Rechner der Programmstart über eine Minute braucht (Weil mehrere Aktoren eine Verbindung zum OPC UA herstellen) und der andere Rechner (identischer Rechner und gleiches Programm) nur ein paar Sekunden.

Bei der Fehlersuche ist mir dann aufgefallen, dass bereits das Connect.vi unterschiedlich lange braucht. Leider kann ich mir das nicht erklären.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
17.05.2021, 16:59
Beitrag #4

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.774
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: OPC UA Connect.vi sehr langsam
Hallo,

und wie sind die Rechner mit dem OPC-UA-Server netzwerktechnisch verbunden?

Spukt mglw. die Firewall oder ein sonstiger Sicherheitsprozess auf dem langsameren System dazwischen? Oder ist dort das Routing hier anders? Ich kenn mich mit OPC-UA nicht aus, aber vielleicht ist es auch eine Einstellung am OPC-Server?

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
19.05.2021, 19:18
Beitrag #5

davtrs Offline
LVF-Neueinsteiger


Beiträge: 4
Registriert seit: May 2021

2017
-
DE



RE: OPC UA Connect.vi sehr langsam
Hallo jg,

die Rechner sind über einen Switch mit dem Hauptrechner (Wo der OPC UA Server läuft) verbunden.

Also kann ich ganz normal über die internen IP (bspw. 192.168.0.4) auf den OPC UA Server verbinden.

Ich habe die Sicherheitseinstellungen und Firewall (McAfee) vergliche und diese sind identisch.

Mich wundert es, dass das anpingen der OPC UA Server IP (192.168.0.1) sowie die Verbindung mittels UaExpert (Ein OPC UA Client) wenige ms braucht ms bzw. s braucht aber über das Connect.vi 10 s.

Ich weiß, dass es eine sehr spezielle Problemstellung ist und es evtl. gar nicht an LabVIEW liegt.

Falls jemand dennoch Ideen hat, wäre ich dem sehr verbunden.

Gruß
David
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
28.05.2021, 10:44
Beitrag #6

davtrs Offline
LVF-Neueinsteiger


Beiträge: 4
Registriert seit: May 2021

2017
-
DE



RE: OPC UA Connect.vi sehr langsam

Akzeptierte Lösung

Hallo zusammen,

ich habe den Rechner neu aufgesetzt und im gleichen Zug Windows 10 installiert.

Das Problem ließ sich damit lösen, also kann das hier geschlossen werden.

Gruß und vielen Dank
David
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  2 Datasocket Read in einer While-Schleife sehr langsam Haarry09 5 4.532 09.09.2010 11:49
Letzter Beitrag: Haarry09

Gehe zu: