INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Dieses Thema hat akzeptierte Lösungen:

VISA Error 1073807339 aber nicht mit Lämpchen an



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

31.05.2021, 11:14
Beitrag #1

Hachiko Offline
LVF-Gelegenheitsschreiber
**


Beiträge: 69
Registriert seit: Sep 2010

201
2010
kA


Deutschland
VISA Error 1073807339 aber nicht mit Lämpchen an
Hallo Forum,

ich komme leider mit einem fertigen Treiber für ein Keysight 53320A nicht weiter.

Es wäre Klasse, wenn mir jemand helfen könnte.

Aufbau: Keysight 53320A am USB-Port über Treiberpaket ansprechen.

Problem:
1. Programm bleibt immer im Error-VI hängen.
2. Im Debug-Modus läuft es durch.
3. Im MAX wird der Befehl ohne Probleme ausgeführt.

Danke schonmal an die Spezialisten.

lv19_img


Angehängte Datei(en) Thumbnail(s)
                   
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
31.05.2021, 12:00
Beitrag #2

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.774
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: VISA Error 1073807339 aber nicht mit Lämpchen an
Hallo Hachiko,

kannst du beim Initialize VI einen Read-Time-Out definieren? Bzw. was ist in diesem VI dafür definiert? Denn ganz offenbar bist du im "Nicht-Highlight-Modus" zu schnell.

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
31.05.2021, 12:59
Beitrag #3

Hachiko Offline
LVF-Gelegenheitsschreiber
**


Beiträge: 69
Registriert seit: Sep 2010

201
2010
kA


Deutschland
RE: VISA Error 1073807339 aber nicht mit Lämpchen an
Hallo Jens,

wir kann ich den Read-Timeout erstellen.

Gibt es für "Read-Timeout" Eigeschaftknoten in VISA dafür?

Mir ist das VI "Default" im Treiber aufgefallen.(siehe Bild Anhang)
Das wurde immer vor dem Error-Vi aufgerufen.

Im MAX habe ich dann den Code von Default und danach *IDN?\n ausgeführt.
Da hatte ich gesehen, dass sich das Gerät aufhängt.
Komischerweiße ging es dann aber zwischendrin im MAX auch mit Default und *IDN?\n.

Jedenfalls habe ich das VI "Default" aus dem Treiber gelöscht, jetzt geht´s. Auch wenn das eher ein Workaround ist.

Das mit dem Read-Timeout würde ich aber gerne nochmal testen.

Mit Timern hatte ich aber bereits schon Versuche gemacht und die Rückmeldung vor und nach der Errorabfrage verzögert. Ging da aber auch nicht


Danke

Hachiko


Angehängte Datei(en) Thumbnail(s)
   
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
31.05.2021, 13:29
Beitrag #4

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.774
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: VISA Error 1073807339 aber nicht mit Lämpchen an
Hallo Hachiko,

wie geschrieben, hat das Initialize VI der Keysight API irgendwelche Eingänge für Timeout-Settings.

Ansonsten, du kannst per PropertyNode jederzeit das Time-Out der Session per PropertyNode ändern (vgl. auch die Einstellungen von VISA Configure Serial Port):

   

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
31.05.2021, 14:05
Beitrag #5

Hachiko Offline
LVF-Gelegenheitsschreiber
**


Beiträge: 69
Registriert seit: Sep 2010

201
2010
kA


Deutschland
RE: VISA Error 1073807339 aber nicht mit Lämpchen an
Hallo Jens,

ich habe den Eigenschaftsknoten mit 2000ms angegeben, jedoch kommt kein Timeout, bzw. das Error-Vi hängt immernoch.
Wenn ich 2ms für Timeout eintrage, kommt direkt nach dem Start eine Timeout-Meldung.

Das Problem, dass das Error-VI aus Timing-Gründen nicht geht, wird vermutlich nicht durch die Eigenschaft Timeout gelöst,
ich bekomme es im Besten Fall angezeigt und das nach der Timeout-Zeit, wenn sie denn geht.

Gibt es eine Lösung, die Ausführung langsamer zu machen oder eine Art Synchronisation?

Gruß

Hachiko


Angehängte Datei(en) Thumbnail(s)
   
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
31.05.2021, 16:12 (Dieser Beitrag wurde zuletzt bearbeitet: 31.05.2021 16:21 von jg.)
Beitrag #6

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.774
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: VISA Error 1073807339 aber nicht mit Lämpchen an
Hallo Hachiko,

vielleicht sind 2 s zu wenig.

Hast du schon mal ergründet, an welcher Stelle im Code der Time-Out-Fehler zuerst auftritt (durch Setzen von Probes, oder durch Aktivieren der "Retain Wire Value Option", nicht durch Highlight-Execution!).

Wobei ich nicht mehr durchblicke, ist deine Aussage, dass es im Error Query hängenbleibt. In einem deiner Screenshots ist hier ein Fehler dargestellt, aber dann bricht die While-Loop doch ab!

Gruß, Jens

EDIT:
Im Wait for Aquisition Complete wird genau das gemacht, was ich vorgeschlagen habe, es wird der Timeout für Read & Write geändert.
   
Schau doch mal, was der Standard-Time-Out ist, denn im Init-VI der API wird der ja gar nicht definiert.

EDIT2:
Nur zur Sicherheit, meinst du ein 53320A (das finde ich bei Keysight nicht, und auch keinen Treiber bei NI) oder ein 53220A ?

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
01.06.2021, 13:32
Beitrag #7

Hachiko Offline
LVF-Gelegenheitsschreiber
**


Beiträge: 69
Registriert seit: Sep 2010

201
2010
kA


Deutschland
RE: VISA Error 1073807339 aber nicht mit Lämpchen an

Akzeptierte Lösung

Hallo Jens,

es handelt sich um ein Keysight 53220A.

Ich habe das Problem jetzt gefunden.

Wenn man das Kommando zum Auslesen des Errorcodes schickt, darf man nicht sofort den Puffer auslesen.

Nach dem Einbau einer Verzögerungszeit von 500ms, kann man ohne Problem auslesen.

Der Standard-Timeout war 2000ms.

Nochmals Danke für den Support.

VG

Hachiko


Angehängte Datei(en) Thumbnail(s)
   
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  Gerät wird im VI nicht mehr erkannt - Problem mit VISA? MissHeadcrusher 10 3.075 25.11.2019 00:14
Letzter Beitrag: rolfk
  VISA Error Code Fehlerbehandlung L@BTR0N 2 2.907 19.02.2019 13:53
Letzter Beitrag: L@BTR0N
  GPIB / VISA Verbindung funktioniert nicht mehr in exe marc10k 2 2.192 25.01.2019 12:15
Letzter Beitrag: marc10k
  VISA über MAX geht, im VI nicht mehr buettnerstefan 7 3.562 29.06.2018 13:02
Letzter Beitrag: buettnerstefan
  Error when control USB Test&Measurement Device using VISA r4Ak5 8 4.916 09.03.2017 16:26
Letzter Beitrag: GerdW
  VISA Gerät wird trotz Sichtbarkeit im MAX im Programm nicht erkannt hulk 4 4.686 19.08.2016 10:34
Letzter Beitrag: hulk

Gehe zu: