INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

NI-DAQmx Counter mit Startschwierigkeiten



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

06.04.2018, 09:47
Beitrag #1

stoa Offline
LVF-Grünschnabel
*


Beiträge: 10
Registriert seit: Apr 2018

2015
2013
DE



NI-DAQmx Counter mit Startschwierigkeiten
Liebe LVF-Gemeinde,

vielen Dank an die vielen, treuen Mitglieder, die Anfängern mit Rat und Tat zur Seite stehen. Das LabVIEW-Forum war für mich schon zu Studienzeiten eine echte Institution! Hoffentlich könnt ihr auch mir mit meinem Problem helfen.

Seit einiger Zeit befasse ich mich nun intensiver mit den NI-DAQmx-Treibern, wobei der Zugang zu diesen nicht immer ganz leicht ist und auch die erhältlichen Schulungsunterlagen didaktisch nicht immer ganz optimal aufgebaut sind oder sie gerade alle erdenklichen Problemlösungen präsentieren - nur nicht gerade die, die man braucht.

Zu meinen Problem:
Der Aufbau:
Ich möchte kontinuierlich zwei Signale synchron aufnehmen. Bei dem ersten vorliegenden Signal handelt es sich um eine Spannung, die ich mit 1000 Hz abtaste und je Schleifendurchlauf 1000 Samples entnehme. Der Schleifendurchlauf liegt demnach bei 1 Sekunde. Beim zweiten Signal handelt es sich um ein PWM-Signal mit einer Frequenz von 3 kHz, das ich über einen Counter aufnehme und den Kanal in NI-DAQmx als "Impulsbreite" konfiguriere. Die Impulsbreite wiederum mit 3000 multipliziert ergibt das Tastverhältnis. Um Synchronität zu erreichen, versehe ich die Impulsbreitenaufnahme mit einem Trigger, der auf den Starttrigger des Analogeingangs angesetzt ist.

Zu erwartendes Verhalten:
Nach Starten des Programms sollten nach 1 Sekunde 1000 Spannungswerte vorliegen und die Abtastrate der Spannungsaufnahme bestimmt die Laufzeit der Schleife. Die Impulsbreitenaufnahme keine festgelegte Sampleanzahl hat, ist dort mit 3000 Impulsbreitenaufnahmen zu rechnen.

Problem:
Nach Starten des Programms liegen nach 1 Sekunde 1000 Spannungswerte vor und 6 (manchmal nur 3 oder 5) Impulsbreitenaufnahmen, nach dem zweiten Schleifendurchlauf 1000 Spannungswerte und 1800 (oder mehr oder weniger) und erst ab dem dritten Schleifendurchlauf dann 1000 Spannungswerte und 3000 (+-1) Impulsbreitenaufnahmen.

Meine Frage: Warum liegen nach dem Start des Programms nicht bereits nach dem ersten Schleifendurchlauf 3000 Impulsbreitenaufnahmen vor? Das PWM-Signal liegt dauerhaft an und bildet einen Sinus ab. Wenn ich die Datenerfassung ohne die Spannungsaufnahme vornehme, gibt es keine "Startschwierigkeiten"...

Ich kann es mir nicht erklären und ich hoffe, jemand hat eine Idee dazu!

Vielen Dank und beste Grüße!
stoa
lv15_img
Gerät: USB-6343
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
09.04.2018, 07:50
Beitrag #2

stoa Offline
LVF-Grünschnabel
*


Beiträge: 10
Registriert seit: Apr 2018

2015
2013
DE



RE: NI-DAQmx Counter mit Startschwierigkeiten
Ich sollte wohl auch das VI hochladen. Das habe ich irgendwie verschwitzt. Nur die Editierfunktion will gerade nicht so recht. Daher muss ich mir gerade mal antworten...


Angehängte Datei(en)
15.0 .vi  PWM_und Spannung.vi (Größe: 40,32 KB / Downloads: 33)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
13.04.2018, 06:36
Beitrag #3

stoa Offline
LVF-Grünschnabel
*


Beiträge: 10
Registriert seit: Apr 2018

2015
2013
DE



RE: NI-DAQmx Counter mit Startschwierigkeiten
Hallo zusammen,

habe ich bei der Erstellung meiner Frage einen Fehler gemacht? Kann ich etwas verbessern oder weiß niemand einen Rat für mich?

Beste Grüße
stoa
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
13.04.2018, 06:55
Beitrag #4

GerdW Online
______________
LVF-Team

Beiträge: 15.510
Registriert seit: May 2009

09SP1, 11SP1, 17
1995
DE_EN

10×××
Deutschland
RE: NI-DAQmx Counter mit Startschwierigkeiten
Hallo stoa,

das Problem dürfte wohl sein, dass niemand einen Rat für dich hat.
Die Fragestellung inkl. VI war prima!

Tipp meinerseits: warum verwirfst du nicht einfach die ersten 2s der Messung, wenn danach alles korrekt läuft?

Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
13.04.2018, 08:08
Beitrag #5

stoa Offline
LVF-Grünschnabel
*


Beiträge: 10
Registriert seit: Apr 2018

2015
2013
DE



RE: NI-DAQmx Counter mit Startschwierigkeiten
Hallo GerdW,

die ersten zwei Sekunden zu verwerfen wird zur Not die Lösung werden. Nur denke ich, dass man vor allem der Lösung des Problems an der Wurzel Aufmerksamkeit widmen sollte und nicht nur Symptome behandeln. Vielleicht kommt der Tag, an dem man die Möglichkeit nicht hat?

Trotzdem vielen Dank für deine Antwort!

mit Gruß
stoa
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
13.04.2018, 08:29
Beitrag #6

IchSelbst Offline
LVF-Guru
*****


Beiträge: 3.555
Registriert seit: Feb 2005

11, 14, 15, 17
-
DE

97437
Deutschland
RE: NI-DAQmx Counter mit Startschwierigkeiten
Stimmt denn bei den 6 bzw. 1800 Samplewerten der Messwert (also ca. 3kHz) ?

Wenn ja:
Obwohl er nicht alle 3000 Samples erfasst, erfasst er diese 6 bzw. 1800 richtig?

Jeder, der zur wahren Erkenntnis hindurchdringen will, muss den Berg Schwierigkeit alleine erklimmen (Helen Keller).
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
13.04.2018, 11:32
Beitrag #7

stoa Offline
LVF-Grünschnabel
*


Beiträge: 10
Registriert seit: Apr 2018

2015
2013
DE



RE: NI-DAQmx Counter mit Startschwierigkeiten
(13.04.2018 08:29 )IchSelbst schrieb:  Stimmt denn bei den 6 bzw. 1800 Samplewerten der Messwert (also ca. 3kHz) ?

Wenn ja:
Obwohl er nicht alle 3000 Samples erfasst, erfasst er diese 6 bzw. 1800 richtig?

Ja, so sieht's aus.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
14.04.2018, 09:29
Beitrag #8

IchSelbst Offline
LVF-Guru
*****


Beiträge: 3.555
Registriert seit: Feb 2005

11, 14, 15, 17
-
DE

97437
Deutschland
RE: NI-DAQmx Counter mit Startschwierigkeiten
(06.04.2018 09:47 )stoa schrieb:  Wenn ich die Datenerfassung ohne die Spannungsaufnahme vornehme, gibt es keine "Startschwierigkeiten"...
Klar.

Grundlagen:
Alles, was nicht sequenziert ist, läuft parallel ab. Klingt blöd, ist aber so.

Warum also ließt du per DAQmx die PWM-Werte mit -1 ein, also alles was gerade anliegt? Dieses Lese-VI wird praktisch sofort nach dem erstmaligen Start der Schleife auch schon wieder beendet: Es wurden gerade mal 6 Samples zwischen Start und Lesen erfasst (Anzahl ist von der Qualität des Rechners abhängig). Bei AIn-Sample ist das anders: hier wartest du auf 1000 Stück - und diese Wartezeit geht beim nächsten Lesen auch in die PWM ein.

Versuche mal, das PWM-Lesen direkt nach dem AIn-Lesen zu machen - also noch vor jeder anderen Berechnung und Anzeige in einem Graph.

Jeder, der zur wahren Erkenntnis hindurchdringen will, muss den Berg Schwierigkeit alleine erklimmen (Helen Keller).
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
20.04.2018, 11:34
Beitrag #9

stoa Offline
LVF-Grünschnabel
*


Beiträge: 10
Registriert seit: Apr 2018

2015
2013
DE



RE: NI-DAQmx Counter mit Startschwierigkeiten
Hallo Ichselbst,

vielen Dank für deine Antwort. Tatsächlich zeigt sich das Verhalten, dass in der ersten Ausführung die Ausgabe der Counter leer bleibt und in der zweiten 3000 Werte enthalten sind. Klingt also soweit ganz gut, nur erklärt sich mir damit die erste leere Sekunde nicht. Die Datenerfassungen sollten doch gleichzeitig starten und eine Sekunde laufen. Werden also nach einer Sekunde die geforderten 1000 AI-Samples abgeholt, sollten doch 3000 (oder auch 3006?) Counterwerte vorhanden sein.

Wer noch Ideen hat, immer raus damit. Beste Grüße und eine schönes Wochenende!

stoa

VI anbei.


Angehängte Datei(en)
15.0 .vi  PWM_und_Spannung_v2.vi (Größe: 42,15 KB / Downloads: 19)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
21.04.2018, 19:04
Beitrag #10

IchSelbst Offline
LVF-Guru
*****


Beiträge: 3.555
Registriert seit: Feb 2005

11, 14, 15, 17
-
DE

97437
Deutschland
RE: NI-DAQmx Counter mit Startschwierigkeiten
(20.04.2018 11:34 )stoa schrieb:  Tatsächlich zeigt sich das Verhalten, dass in der ersten Ausführung die Ausgabe der Counter leer bleibt und in der zweiten 3000 Werte enthalten sind.
Aus dieser Aussage folgere ich folgendes: Trotzdem die DAQmx-Lese-VIs von AIn und Zähler sequenziert sind (siehe zweites VI), erhälst du beim ersten Lesen der Zähler-Task keine (oder maximal 15) Werte. Erst beim zweiten Mal Lesen erhälst du die erwartete Anzahl.

Stimmt das so?

Wenn ja, dann probierst du folgendes: Mache einmal sequenziert zwischen Start der AIn-Task und While-Schleife ein Zähler-Lesen mit der Anzahl 3. Dann berichtest du, ob alles offensichtlich richtig geht oder ob die Analog-Task einen Fehler bringt.

Jeder, der zur wahren Erkenntnis hindurchdringen will, muss den Berg Schwierigkeit alleine erklimmen (Helen Keller).
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Gehe zu: