INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Dieses Thema hat akzeptierte Lösungen:

Abtastrate bzw. Grundlagen



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

08.06.2016, 07:25
Beitrag #1

mmk1988 Offline
LVF-Grünschnabel
*


Beiträge: 15
Registriert seit: Apr 2016

2012
-
DE



Abtastrate bzw. Grundlagen
Hallo,
ich bin neu in Labview und hätte da mal ein paar Grundlegende fragen.
Ich arbeite mit einem Steuergerät welches analoge Ausgänge hat.
Wenn ich ein Multimeter anschließe zeigt mir dieses einen Konstanten Wert an(z.b 0,533V), den mir auch das Display des Steuergeräts ausgibt.
So bald ich aber ein VI erstelle und mir die Werte Anzeigen lasse, schwanken diese im bereich von +/- 0,01V.
Kann mir jemand Verraten wie ich dieses Verhalten in den Griff bekomme?
Ich habe die Vermutung das es an der Abtastrate liegt, nur habe ich keine Ahnung wie ich herausfinde welche die Richtige für das Gerät ist.

Gruß MMK
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
08.06.2016, 08:32 (Dieser Beitrag wurde zuletzt bearbeitet: 08.06.2016 08:45 von Lucki.)
Beitrag #2

Lucki Offline
Tech.Exp.2.Klasse
LVF-Team

Beiträge: 7.699
Registriert seit: Mar 2006

LV 2016-18 prof.
1995
DE

01108
Deutschland
RE: Abtastrate bzw. Grundlagen
Multimeter sind erdfrei: es gibt da keine Probleme Erdschleifen & Co. Außerdem: Multimeter messen in der Regel integrierend, d.h. Mittelwert bildend. (Dafür ist die Abtastrate gering.) Wenn die Integrationszeit 20 ms ist, werden 50 Hz Netzstörungen herausgefiltert, ist sie sie 100 ms, dann sogar 50 und 60 Hz Störungen.
Statt einer niedrigen Abtastrate ist es immer besser, ein höhere Abtastrate zu wählen und diese durch Mittelwertbildung nachträglich auf den tatsächlich gewünschten Wert zu reduzieren. (Tip: Bei Summierung über 20 ms oder ein Vielfaches werden Brummeinstreuungen entscheidend reduziert)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
08.06.2016, 09:24
Beitrag #3

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.864
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: Abtastrate bzw. Grundlagen
(08.06.2016 07:25 )mmk1988 schrieb:  So bald ich aber ein VI erstelle und mir die Werte Anzeigen lasse, schwanken diese im bereich von +/- 0,01V.
Was macht dein VI? Misst es die Analogausgabe deines Steuergeräts? Wie? Mit welcher Hardware? Wie hast du was verdrahtet? Oder steuerst du das Steuergerät an? Wie? Was macht dann dein VI? Fragen über Fragen auf Grund deiner unvollständigen Informationen.

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
08.06.2016, 15:50 (Dieser Beitrag wurde zuletzt bearbeitet: 08.06.2016 16:00 von mmk1988.)
Beitrag #4

mmk1988 Offline
LVF-Grünschnabel
*


Beiträge: 15
Registriert seit: Apr 2016

2012
-
DE



RE: Abtastrate bzw. Grundlagen
Es handelt sich um den NI USB-6001.
Mein VI soll nichts anderes machen als den Analogen Spannungswert anzeigen.
Das Steuergerät welches über die entsprechenden ausgänge verfügt ist eine spezialanfertigung. Daher kann ich darüber nichts sagen.
Mein Ziel:
Ich möchte das der Wert genauso konstant angezeigt wird wie mit dem Multimeter beschrieben.
Ich habe den analogen Ausgang des Steuergeräts direkt mit dem analogen input des NI verbunden .
Ich habe den DAQ Assi verwendet, meinen eingang gewählt und konfiguriert RSE/Differentielle anschlussart probiert und mit den samples/hertz der endlichen messung experimentiert. Leider immer mit dem oben beschrienen ergebniss
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
09.06.2016, 12:16 (Dieser Beitrag wurde zuletzt bearbeitet: 09.06.2016 12:17 von Lucki.)
Beitrag #5

Lucki Offline
Tech.Exp.2.Klasse
LVF-Team

Beiträge: 7.699
Registriert seit: Mar 2006

LV 2016-18 prof.
1995
DE

01108
Deutschland
RE: Abtastrate bzw. Grundlagen
Zitat:Ich habe den DAQ Assi verwendet, meinen eingang gewählt und konfiguriert RSE/Differentielle anschlussart probiert und mit den samples/hertz der endlichen messung experimentiert.
..und meinen Vorschlag zur Mittelwerbildung ignoriert. Tja, dann kann man wirklich nichts mehr machen.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
09.06.2016, 17:59
Beitrag #6

mmk1988 Offline
LVF-Grünschnabel
*


Beiträge: 15
Registriert seit: Apr 2016

2012
-
DE



RE: Abtastrate bzw. Grundlagen
Zu erst solltest du mal dringend von deinem hohen Roß runter kommen.
Ich habe bereits im Vorfeld eine Mittelwertsbidung gemacht, mit jeweils (bis zu) 300 Messungen, es hat sich aber KAUM gebessert. Deswegen denke ich das dies nicht mein Problem ist.
Ich glaube das es ein Frequenz bzw generelles Anschlussproblem ist.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
09.06.2016, 18:32
Beitrag #7

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.864
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: Abtastrate bzw. Grundlagen
(09.06.2016 17:59 )mmk1988 schrieb:  Zu erst solltest du mal dringend von deinem hohen Roß runter kommen.
Ich habe bereits im Vorfeld eine Mittelwertsbidung gemacht, mit jeweils (bis zu) 300 Messungen, es hat sich aber KAUM gebessert. Deswegen denke ich das dies nicht mein Problem ist.
Ich glaube das es ein Frequenz bzw generelles Anschlussproblem ist.
Vorsicht mit solchen Sprüchen gegenüber einem Admin! Dasselbe gilt übrigens für dich. Woher sollen wir wissen, dass du eine MW-Bildung durchgeführt hast? Jetzt verraten und sich dann auf den Schlips getreten fühlen, das finde ich keinen guten Stil.

Deine Angaben sind weiterhin unvollständig. Du vermutest Anschlussprobleme, verrätst aber nichts darüber, was du wie genau verdrahtet hast. Und welchen Messmodus hast du bei welcher Verdrahtung verwendet?

Eine Aussage "mitteln über 300 Messungen" ist ebenfalls nicht sonderlich aussagekräftig. Was bedeutet bei dir "eine Messung"? Ist das eine Einzelwerterfassung? Oder schon eine hardwaregetakte Messreihe, z.B. über 1 Sekunde? Oder oder oder. DAQAssi kann auch alles mögliche bedeuten, von Einzelwerterfassung im Softwaretakt bis zu einer kontinuierlichen Messung mit hoher Erfassungsrate.

Also: Bitte genaue Angaben über deine Anschlüsse und vielleicht noch ein VI hochladen...

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
11.06.2016, 18:01
Beitrag #8

mmk1988 Offline
LVF-Grünschnabel
*


Beiträge: 15
Registriert seit: Apr 2016

2012
-
DE



RE: Abtastrate bzw. Grundlagen

Akzeptierte Lösung

Habe ich das Richtig gelesen?
Eine pampige Antwort darf also nicht kritisiert werden weil die betroffene Person ein Teammitglied ist?
Ist das euer ernst? Bitte macht euch nicht lächerlich.
BTW, das Problem habe ich selbst gelöst. Ich dachte hier wären Experten unterwegs die einem sagen könnten, dass man einfach nur einen Filter auf das Eingangssignal setzen kann.
Wenn man es weiß, easy. Als Neuling im ersten Schuss nicht klar.
Schade das man sich sowas im "Labviewforum" selbst beantworten muss.

Mit freundlichen Grüßen,

MMK
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
12.06.2016, 13:41
Beitrag #9

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.864
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: Abtastrate bzw. Grundlagen
Offtopic2
(11.06.2016 18:01 )mmk1988 schrieb:  Habe ich das Richtig gelesen?
Eine pampige Antwort darf also nicht kritisiert werden weil die betroffene Person ein Teammitglied ist?
Ist das euer ernst? Bitte macht euch nicht lächerlich.
Das kann ich so nicht stehenlassen. Ich mag hier generell keine pampigen Antworten. Das ist vielleicht falsch rübergekommen. Aber ja, gegenüber den Admins des Forums fordere ich ein wenig mehr Respekt. Und auch wenn du das anderes sehen magst, IMHO war deine Antwort pampig, nicht die von Lucki.
(11.06.2016 18:01 )mmk1988 schrieb:  BTW, das Problem habe ich selbst gelöst. Ich dachte hier wären Experten unterwegs die einem sagen könnten, dass man einfach nur einen Filter auf das Eingangssignal setzen kann.
Wenn man es weiß, easy. Als Neuling im ersten Schuss nicht klar.
Schade das man sich sowas im "Labviewforum" selbst beantworten muss.

Mit freundlichen Grüßen,

MMK
Was ist eine Mittelwertildung anderes als ein Filter? Du musstest dir also nicht selber die Antwort liefern, du hast sie bekommen. Aber BTW, was ist daran so schlecht, du hast selber etwas gelernt und herausgefunden - das ist doch prima!!!

Dass du dir jetzt auf den Schlips getreten fühlst, daran kann ich wahrscheinlich nichts mehr ändern. Stell das nächste Mal einfach ausführlicher und genauer dein Problem dar, dann bekommst du sicherlich schnell Hilfe (wie gefühlt 99% der Threads beweisen).

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  Abtastrate von Anzeigeelementen entkoppeln Titus 3 3.938 07.06.2016 07:20
Letzter Beitrag: GerdW
  Drehmoment Winkel XY-Diagramm und Abtastrate Jonnybo 1 4.568 05.06.2016 20:00
Letzter Beitrag: GerdW
  Abtastrate einstellen ! CarpPredator 5 9.195 25.02.2015 12:40
Letzter Beitrag: Lucki
  NI 9205 Abtastrate Sabrina89 2 4.209 06.11.2014 15:20
Letzter Beitrag: Sabrina89
  cDAQ 9172 unterschiedene Abtastrate radnaib 10 9.077 29.01.2013 17:44
Letzter Beitrag: Peter77
  Daten erfassen in 1ms Abtastrate regis57 4 5.306 03.12.2012 16:22
Letzter Beitrag: regis57

Gehe zu: