INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Fehler 1 bei Datei schließen in VI



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

16.07.2018, 10:55
Beitrag #1

VibLab Offline
LVF-Neueinsteiger


Beiträge: 6
Registriert seit: Jul 2018

14.0
-
DE



Fehler 1 bei Datei schließen in VI
Hallo miteinander,

innerhalb meines VIs werden Daten in eine Datei geschrieben. Immer beim Beenden bekomme ich eine Fehlermeldung mit dem Fehler 1 (Screenshot im Anhang).
Innerhalb des Dateipfades sind keinerlei ? oder @ oder ähnliches enthalten. Lediglich Umlaute, / und normale Buchstaben.
Weiß jemand was diese Fehlermeldung verursacht? Die Daten werden trotzdem korrekt in der Datei gespeichert, allerdings hätte ich gerne nicht jedes Mal eine Fehlermeldung.
Ich verwende LabVIEW 14.0

Vielen Dank für die Unterstützung!

MfG
Martin


Angehängte Datei(en) Thumbnail(s)
   
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
16.07.2018, 11:32
Beitrag #2

GerdW Offline
______________
LVF-Team

Beiträge: 16.018
Registriert seit: May 2009

09SP1, 11SP1, 17 (18)
1995
DE_EN

10×××
Deutschland
RE: Fehler 1 bei Datei schließen in VI
Hallo VibLab,

Zitat:Weiß jemand was diese Fehlermeldung verursacht?
Ein ungültiger Parameter beim Aufruf dieser Funktion…
Genaueres findest du heraus, wenn du dein VI debuggst - oder uns mal hier durch Anhängen bereitstellst!

Zitat:allerdings hätte ich gerne nicht jedes Mal eine Fehlermeldung.
Das Schöne an solchen Fehlermeldungen ist doch, dass man sie programmatisch abfangen/auswerten kann.
Hast du aber anscheinend nicht gemacht… Sad

Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
16.07.2018, 12:40
Beitrag #3

VibLab Offline
LVF-Neueinsteiger


Beiträge: 6
Registriert seit: Jul 2018

14.0
-
DE



RE: Fehler 1 bei Datei schließen in VI
danke für die schnelle Antwort. Im Anhang befindet sich das VI. Für mich ist es nicht ersichtlich welcher Parameter dabei ungültig ist...


Angehängte Datei(en)
14.0 .vi  Vibrometer_V13_Fehler1.vi (Größe: 127,43 KB / Downloads: 81)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
16.07.2018, 13:00 (Dieser Beitrag wurde zuletzt bearbeitet: 16.07.2018 13:02 von GerdW.)
Beitrag #4

GerdW Offline
______________
LVF-Team

Beiträge: 16.018
Registriert seit: May 2009

09SP1, 11SP1, 17 (18)
1995
DE_EN

10×××
Deutschland
RE: Fehler 1 bei Datei schließen in VI
Hallo VibLab,

Zitat:Für mich ist es nicht ersichtlich welcher Parameter dabei ungültig ist...
- Der "Dateiname" ist leer: damit hat Windows so seine Probleme…
- Da fehlen ÜBERALL die Error-Drähte an den File-Funktionen! Wie willst du also feststellen, wo der Fehler WIRKLICH auftritt?
- Deine Case-Struktur gibt im FALSE-Case eine ungültige Referenz aus, die kann LabVIEW einfach nicht schließen…

Nochmal:
- Hast du dein VI schon mal debuggt?
- Hast du den Pfad, den du da erzeugst, wirklich auf Korrektheit (und zur Sicherheit auch die Schreibrechte) überprüft?
- Referenzen gehören in Schieberegister, wenn sie durch Schleifen durchlaufen…

P.S.: AutoCleanup schadet auch nicht… Big Grin

Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
16.07.2018, 16:04
Beitrag #5

VibLab Offline
LVF-Neueinsteiger


Beiträge: 6
Registriert seit: Jul 2018

14.0
-
DE



RE: Fehler 1 bei Datei schließen in VI
Hallo GerdW,

vielen Dank für deine Hilfe. Ja das VI ist noch ein wenig in der "Rohbauphase", deswegen sieht es auch noch nicht sonderlich hübsch aus. Das kommt später noch. Der Dateiname wird vor dem Programmstart entsprechend der anstehenden Messung ausgefüllt und ist korrekt (Schreibrechte sind auch vorhanden) Wink Die Fehlerdrähte habe ich noch alle hinzugefügt und die Referenzleitung ebenfalls angepasst.

Was verstehst du unter VI debuggen? Welche Schritte sind dafür sinnvoll?

LG
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
16.07.2018, 17:58 (Dieser Beitrag wurde zuletzt bearbeitet: 16.07.2018 17:58 von GerdW.)
Beitrag #6

GerdW Offline
______________
LVF-Team

Beiträge: 16.018
Registriert seit: May 2009

09SP1, 11SP1, 17 (18)
1995
DE_EN

10×××
Deutschland
RE: Fehler 1 bei Datei schließen in VI
Hallo viblab,

einfach mal die Glühlampe anschalten und den Dataflow zuschauen (Highlight-Debugging). Oder ein paar Sonden platzieren und schauen, welche Werte an diesen Stellen im Programm auftreten...

Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
16.07.2018, 20:02
Beitrag #7

jg Offline
CLD & CLED
LVF-Team

Beiträge: 15.407
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: Fehler 1 bei Datei schließen in VI
(16.07.2018 13:00 )GerdW schrieb:  - Deine Case-Struktur gibt im FALSE-Case eine ungültige Referenz aus, die kann LabVIEW einfach nicht schließen…
Das ist mein Favorit.

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  Fehler in Text Datei schreiben (Loggen). Lennard 7 4.372 24.06.2014 21:14
Letzter Beitrag: jg
  Sporadischer Fehler beim ini-Datei schreiben JohnnyBlack 4 3.390 14.06.2013 18:35
Letzter Beitrag: Holy
  Fehler bei Datei erstellen im FPGA-Modus TobiasMo 2 2.749 14.03.2012 17:03
Letzter Beitrag: jg
  Fehler 4 - Ende der Datei (EOF) festgestellt? Hilfe! SteveO 8 7.692 15.02.2010 21:38
Letzter Beitrag: jg
  Konfig-Datei schließen Fehler dr.deejay 1 2.093 02.09.2009 22:38
Letzter Beitrag: jg
  Datei-I/O-Fehler beim abspeichern von VIs LabYouToo 4 4.633 07.03.2009 11:24
Letzter Beitrag: Lucki

Gehe zu: