INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Dieses Thema hat akzeptierte Lösungen:

Kurioses Timing / cDAQ NI9234



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

05.09.2014, 22:31
Beitrag #1

Zosch Offline
LVF-Neueinsteiger


Beiträge: 2
Registriert seit: Sep 2014

2010
2014
DE



Kurioses Timing / cDAQ NI9234
Liebe Labview-Gemeinde,

im Prinzip versuche ich nichts weiter, als mit der genannten Karte (zusammen mit einer NI9263 im cDAQ-9178-rack) ein Spannungssignal zu messen. Ich weiß auch, dass ich abhängig von der Timingquelle nicht jede Abtastrate einstellen kann, aber was die Karte (oder mein Vi) aus meiner Vorgabe macht, ist mit Sicherheit nicht richtig.
Siehe hierzu das angehangene Bild und vi.
Zum Bild: Wie man sieht, gebe ich als (extreme) Abtastfrequenz 1Hz an, daraus werden aber 1651,6Hz. Ähnliches gilt auch für andere/höhere Frequenzen. Da ist doch was faul. Das gleiche Bild bekomme ich auch, wenn ich direkt über den M&A-Explorer einen Task generiere und das Ergebniss im Übersichtsfenster ausführe.
Eine andere Timingquelle (cDAQ1 80/20MHzTimebase) lässt sich auch nicht einstellen.

Was mach ich falsch, oder ist das ein Hardware/Treiber-Problem?

Ich würde mich über eure Unterstützung freuen.

Gruß


Angehängte Datei(en) Thumbnail(s)
   

10.0 .vi  timing_test.vi (Größe: 23,65 KB / Downloads: 150)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
06.09.2014, 09:05 (Dieser Beitrag wurde zuletzt bearbeitet: 06.09.2014 09:21 von jg.)
Beitrag #2

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.787
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: Kurioses Timing / cDAQ NI9234

Akzeptierte Lösung

Wenn du schon weißt, dass ein 9234 (auf Grund des Delta Sigma Verfahrens) nur bestimmte Datenraten erlaubt, wieso liest du dir nicht die Specs durch?
http://www.ni.com/pdf/manuals/374238c.pdf Seite 16, 18 & 19.
Auf Seite 16 wird erklärt, welche Datenraten mit der internen Master Timebase möglich sind, und da ist das kleinste halt 1652 kS/s.

Auf Seite 19 steht dann, dass die kleinstmögliche Rate bei Verwendung einer externen Master Timebase 391 S/s beträgt.

So weit ich auf die Schnelle verstehe, kann man übrigens nur die Master Timebase von solchen DeltaSigma Modulen (also z.B. 9234, 9237) unter den Modulen teilen und nicht jede beliebige externe Timebase routen.

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
06.09.2014, 09:38
Beitrag #3

GerdW Offline
______________
LVF-Team

Beiträge: 17.029
Registriert seit: May 2009

11SP1, 17SP1 (ab und zu 20)
1995
DE_EN

10×××
Deutschland
RE: Kurioses Timing / cDAQ NI9234
Hallo Zosch,

neben dem schon erfolgten Hinweis auf das immer wieder hilfreiche Manual:
Genau diese Problematik mit eben diesem Messmodul wurde schon des öfteren behandelt. Einfach mal eine Websuche starten hat nicht gefruchtet?

Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
06.09.2014, 12:30
Beitrag #4

Zosch Offline
LVF-Neueinsteiger


Beiträge: 2
Registriert seit: Sep 2014

2010
2014
DE



RE: Kurioses Timing / cDAQ NI9234
Vielen Dank für Eure schnellen Antworten,

auf die Idee mit dem Manual hätte ich ja wirklich auch allein kommen können/müssen - manchmal steht man hallt echt auf dem Schlauch.
Das man nicht jede Rate angeben kann, wusste ich ja (mein eigentliches Hauptprogramm sollte das eigentlich auch abfangen), aber das die Rate nach unten beschränkt ist, das war mir neu und passt auch (noch) nicht in mein Messtechnikverständnis.
Andere Beiträge haben sich auch meist nur mit höheren Raten beschäftigt - die für mich interessanten hab ich wohl übersehen.

Asche auf mein Haupt und eine tiefe Verbeugung.

Vielen Dank

(Banales) Problem gelöst
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  cDAQ Rack USB Masseschleife MaxP 3 3.163 26.03.2019 09:06
Letzter Beitrag: jg
  Triggersignal auslesen von cDAQ-9178, aber wie? Markus F. 7 3.838 26.02.2016 12:38
Letzter Beitrag: GerdW
  NI 9403 für cDAQ als open collector Ausgang Maddin83 8 4.465 23.03.2015 10:10
Letzter Beitrag: Maddin83

Gehe zu: