INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

.NET Events in LabView verarbeiten



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

31.10.2019, 09:22
Beitrag #1

Alex Egg Offline
LVF-Neueinsteiger


Beiträge: 1
Registriert seit: May 2019

2016
2017
EN


Deutschland
.NET Events in LabView verarbeiten
Hallo zusammen,


nachdem ich dieses und andere LabView-Foren durchackert habe und für mein aktuelles Problem keine Lösung gefunden habe, verfasse ich nun selbst meinen ersten Beitrag. Angel_not
Die Aufgabenstellung klingt eigentlich recht simpel: Es ist ein Programm zum Testen einer Baugruppe in LabView zu erstellen, welches mehrere Kunden-DLLs (.NET) verwendet. Ich habe vom Kunden auch ein Beispiel-Programm erhalten, aus dem ich den genauen Ablauf "abschreiben" konnte. So weit, so gut. Mein LabView-Programm funktioniert auch und kann alle Schritte ausführen, ich kann auch die notwendigen Properties aus den .NET-Referenzen auslesen.
Aber das Testen geht nur erfolgreich mit Teilen, die mit dem "alten" Testprogramm getestet wurden. Denn im alten Programm wird während dem Durchführen des Tests über Events ein spezieller Boolean gesetzt. Und hier ist das Problem: Ich kann dieses Event nicht verarbeiten. Wie gesagt habe ich mich schon wegen Lösungen umgesehen, auch bevor ich diese Aufgabe angegangen bin, und ich dachte, ich habe dieses Thema "verstanden"... scheint wohl nicht so. Ich hatte diesen Blogeintrag als Guide genommen: http://fabiantoepper.de/net-events-in-la...ar-machen/
Und angehängt findet ihr auch Screenshots zu meinem Programmaufbau. Im "Test starten" SubVI wird nur mit einer Invoke Node der Test gestartet. LabView bleibt dann an dieser stelle stehen und geht erst weiter, wenn der Test fertig ist. Ich kann mir vorstellen, dass das eventuell das Problem ist, jedoch habe ich keine Ahnung, wie ich das umgehen/lösen kann. Die Inhalte der Callback VIs habe ich aus dem Beispielprogramm vom Kunden genommen. Ich habe testweise dort auch Dialogfenster eingebaut, um zu sehen, ob diese Events triggern, aber vergeblich. Keine Fenster... Blink
Es wird LabView 2016 verwendet und wir haben darauf geachtet, dass die .NET DLLs auch kompatibel sind. Ich kann diese DLLs leider nicht zur Verfügung stellen oder mehr vom Code zeigen. Dennoch hoffe ich, dass mir jemand helfen kann.
Ich bedanke mich schon im Voraus für eure Unterstützung!

Mit freundlichen Grüssen,
Alex Egg


Angehängte Datei(en) Thumbnail(s)
               
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
31.10.2019, 18:22
Beitrag #2

IchSelbst Offline
LVF-Guru
*****


Beiträge: 3.641
Registriert seit: Feb 2005

11, 14, 15, 17, 18
-
DE

97437
Deutschland
RE: .NET Events in LabView verarbeiten
Hast du schon mal hier im Forum gekuckt nach den diversen Fragem, die dich mit .Net-Callback befassen? Hier wäre einer: https://www.labviewforum.de/showthread.php?tid=31543.

Der Link nach Fabian Töpper ist schon mal gut.

Jeder, der zur wahren Erkenntnis hindurchdringen will, muss den Berg Schwierigkeit alleine erklimmen (Helen Keller).
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
30
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
Question PDF-Dateien als String einlesen und verarbeiten F.Bi 0 2.566 13.12.2016 10:04
Letzter Beitrag: F.Bi
  Events eines eigenen ActiveX Control werden nicht von LabView gefangen Katja 2 3.444 05.03.2014 09:03
Letzter Beitrag: Katja

Who read this thread?
1 User(s) read this thread:
Alex Egg

Gehe zu: