INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Probleme mit PXI-6508 Digitalkarte



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

05.04.2005, 11:07
Beitrag #1

duke1975 Offline
LVF-Neueinsteiger


Beiträge: 1
Registriert seit: Apr 2005



kA



Probleme mit PXI-6508 Digitalkarte
Hallo!

Habe folgendes Problem:
Möchte Pins toggeln (von Port0-Port7), Port8 Pin0,Pin1 sollen für Relaisansteuerung unabhängig vom Toggeln benutzbar sein.

Mein Lösung umfasst ein GroupConfig(Port0-Port7) und ein PortConfig(Port8). Ich schreibe mit WriteToDigLine auf Port 0 bis Port7 um dort beliebige Pins toggeln zu können. Mittels PortWrite schreibe ich auf Port8 um die notwendigen Relais zu schalten.

Dies alles funktioniert bei einwandfrei wenn Pins im Bereich Port0-Port5 getoggelt werden.

Möchte ich allerdings Pins in den Port6 und Port7 toggeln, wird plötzlich Port8 zurückgesetzt.

Ich habe absolut keine Erklärung warum die Ports 0 bis 5 funktionieren und dann plötzlich bei Port 6 u. Port7 das Port 8 manipuliert wird.

Falls irgenjemand Rat zu diesem Problem weiß, bitte ich um Hilfe

Danke
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
30
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  TTL-Erfassung mit Digitalkarte iPaul 2 3.134 27.09.2011 09:21
Letzter Beitrag: iPaul

Gehe zu: