INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Dieses Thema hat akzeptierte Lösungen:

Webserver Applikation erstellen und starten



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

17.09.2019, 12:57
Beitrag #1

Kanaille Offline
LVF-Grünschnabel
*


Beiträge: 12
Registriert seit: Feb 2018

17
2017
DE



Webserver Applikation erstellen und starten
Hallo,

ich bin dabei einen Webserver aufzusetzen damit ich Daten im internen Netzwerk, über den Browser (HTML) darstellen bzw. zur Verfügung stellen kann.

Die Programme an sich laufen und ich kann mit meinen Programmen im Browser abbilden was ich mir so vorgestellt habe. Es ist mir auch geglückt meinen Webserver zu veröffentlichen und ihn über einen anderen Rechner abzufragen, aber nur in der Entwicklungsumgebung. Ich habe dafür die Rechner direkt miteinander verbunden und ein eigenes Netzwerk erstellt. In dem „großen“ lokalen Netzwerk habe ich es nicht geschafft, ich denke das die Firewall da den Riegel vorschiebt.

Ich würde gerne eine Applikation oder einen Installer erstellen, um den Webserver dann auf einem anderen Rechner laufen zu lassen. Vielleicht kann ich so auch das Problem mit der Firewall umgehen, wenn ich die App für die Firewall freigeben. Mir ist klar, dass man das machen kann und ich habe es natürlich auch schon probiert. Das ich bei dem Build, unter Webserver meinen erstellten auswählen muss, ist mir auch bewusst. Hab auch versucht mir das anhand der gängigen Beispiele zu erklären, hab’s aber irgendwie nicht hinbekommen.

Wenn ich eine Installationsdatei erstelle und diese installiere, finde ich die Anwendung danach nicht und kann den Webserver nicht starten. Beim Erstellen einer normalen Applikation .exe packe ich das Haupt-VI in startup VI, was muss ich denn bei einem Webserver als Startup-VI angeben? Es gibt ja nicht so direkt ein Haupt-VI.

Hat jemand von euch schon mal einen Installer mit Webserver erstellt, und kann kurz erklären was man beim Erstellen dieses Installer alles auswählen muss, und wie man ihn dann startet?

Vielen Dank
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
18.09.2019, 13:45 (Dieser Beitrag wurde zuletzt bearbeitet: 19.09.2019 06:45 von Kanaille.)
Beitrag #2

Kanaille Offline
LVF-Grünschnabel
*


Beiträge: 12
Registriert seit: Feb 2018

17
2017
DE



RE: Webserver Applikation erstellen und starten

Akzeptierte Lösung

Hallo,

vielen Dank an all die, die sich das angesehen haben.

Ich habe meinen Fehler gefunden. Ich hatte im Projekt ausschließlich einen Webserver angelegt, aber kein "normales"-VI. Das hat alles in der Entwicklungsumgebung funktioniert, aber warum soll man auch nur einen Webserver in LV erstellen, wenn man dafür auch HTML und Apache hat. Macht ja so auch keinen Sinn. ^^ Ich konnte kein Startup VI bei der Applikation auswählen und im Installer war quasi nichts was man starten konnte.

Auf Jeden Fall habe ich jetzt ein main.vi erstellt und lass mir über eine globale Variable jede Sekunde eine Zufallszahl in mein Webserver-VI übergibt. Das main.vi als Start-Vi angegeben, build gemacht, gestartet und siehe da, Firewall meckert, zugelassen, läuft. Cool

Problem war nur das LabVIEW so einen Quatsch zulässt.

Gruß
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  Hlife bei meinem Webserver tomanek99 0 1.043 28.11.2018 12:22
Letzter Beitrag: tomanek99
  Webserver emir2707 6 2.496 16.03.2016 16:11
Letzter Beitrag: jg
  Webserver funktioniert nur im debug Modus kraesy 0 1.841 08.07.2015 11:39
Letzter Beitrag: kraesy
  NI Webserver knq 6 4.703 15.06.2015 22:03
Letzter Beitrag: knq
  Probleme mit Webserver cheffd 4 3.456 08.04.2014 14:16
Letzter Beitrag: cheffd
  Webserver Client simulieren angry_Nameless 7 3.026 28.05.2013 14:39
Letzter Beitrag: snuz

Gehe zu: