INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

CANopen und XNET



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

26.09.2014, 15:21
Beitrag #11

GerdW Offline
______________
LVF-Team

Beiträge: 16.252
Registriert seit: May 2009

11SP1, 17SP1 (ab und zu 19)
1995
DE_EN

10×××
Deutschland
RE: CANopen und XNET
Hallo Georg,

kannst du dein Beispiel auch nochmal für LV2011 bereitstellen?

Und bitte auch dein Profil anpassen…

Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
29.09.2014, 07:37
Beitrag #12

gfzk Offline
LVF-Grünschnabel
*


Beiträge: 45
Registriert seit: Sep 2009

2012
2007
DE_EN

76344
Deutschland
RE: CANopen und XNET
Hallo Gerd, mach ich doch gerne.

Gruß, Georg


Angehängte Datei(en)
0.0 .zip  CAN Beispiel LV 2011.zip (Größe: 57,65 KB / Downloads: 194)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
19.04.2017, 07:50
Beitrag #13

Max_LabVIEW Offline
LVF-Grünschnabel
*


Beiträge: 13
Registriert seit: Feb 2017

2016
2017
DE_EN


Deutschland
RE: CANopen und XNET
Hallo
stehe vor einem Ähnlichen Problem. Ich bekomme kein Telegramm zurück. Ich bekomme immer den Fehlercode 1074384758 angezeigt. Wie öffne ich die Session und timed loop?
Bahn
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
19.04.2017, 08:03
Beitrag #14

GerdW Offline
______________
LVF-Team

Beiträge: 16.252
Registriert seit: May 2009

11SP1, 17SP1 (ab und zu 19)
1995
DE_EN

10×××
Deutschland
RE: CANopen und XNET
Hallo Max,

Zitat:stehe vor einem Ähnlichen Problem.
Also ein anderes Problem? Und wo ist dein VI?

Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
19.04.2017, 08:10
Beitrag #15

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.468
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: CANopen und XNET
Dann schauen wir mal, was "-1074384758" bedeutet:

Zitat:NI-XNET: (Hex 0xBFF6308A) The interface name given does not specify a valid and existing interface. Solution: Use a valid and existing interface. These can be obtained using MAX, XNET system properties, or the LabVIEW XNET Interface IO name.

Du sprichst also nicht das Interface an. Wieso, weshalb, warum, das sagt mit meine Glaskugel leider nicht. Glas2 Das kann wahrscheinlich nur ein Blick auf deinen Sourcecode verraten.

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
21.04.2017, 12:31
Beitrag #16

Max_LabVIEW Offline
LVF-Grünschnabel
*


Beiträge: 13
Registriert seit: Feb 2017

2016
2017
DE_EN


Deutschland
RE: CANopen und XNET
Den Fehler habe ich nun behoben. Habe den Treiber auf dem PXI Repetiert.AMME
Ich möchte nun mehrere Telegramme senden. Aber für das senden weitere Telegramme ist die Voraussetzung eine Antwort der letzten Telegramme. Wie realisiere ich das am besten?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
21.04.2017, 12:36
Beitrag #17

GerdW Offline
______________
LVF-Team

Beiträge: 16.252
Registriert seit: May 2009

11SP1, 17SP1 (ab und zu 19)
1995
DE_EN

10×××
Deutschland
RE: CANopen und XNET
Hallo Max,

bitte nicht parallel die Frage in zwei Threads stellen!
Hier geht's zur neuen Frage

Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  Xnet auf cRIO: DBC deployen nicht funktioniert Felix777 14 10.944 18.10.2017 06:09
Letzter Beitrag: Felix777
  XNET-Module auf cRIO jg 5 6.006 25.08.2017 10:16
Letzter Beitrag: jg
  XNET Create Session Error hoal 0 6.652 24.02.2016 14:06
Letzter Beitrag: hoal
  NI-XNET Problem mit NI VeriStand Luk-Labviewforum 0 5.564 24.04.2014 10:16
Letzter Beitrag: Luk-Labviewforum
  ServoVerstärker über CanOpen synchronisieren Guest 0 3.168 16.06.2008 13:12
Letzter Beitrag: Guest

Gehe zu: