INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Dieses Thema hat akzeptierte Lösungen:

DAQmx schreiben und lesen



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

05.09.2018, 08:41 (Dieser Beitrag wurde zuletzt bearbeitet: 05.09.2018 08:55 von Sakis.)
Beitrag #1

Sakis Offline
LVF-Grünschnabel
*


Beiträge: 11
Registriert seit: Sep 2018

2013
-
DE


Deutschland
DAQmx schreiben und lesen
Hallo,

ich beschäftige mich nun seit etwa einem Monat mit LabVIEW, habe aber noch keine große Erfahrung mit DAQmx.
Nun stehe ich vor folgendem Problem: Ich möchte an meiner USB-6211 Karte am analogen Output ein Signal (Sinus) ausgeben und das gleiche Signal an einem analogen Input wieder einlesen. Dafür habe ich die Kanäle AO0 und AI1 mit einem Draht verbunden. Im FP habe ich mir dafür zwei Graphen erstellt, die mir das ausgehende bzw. eingehende Signal anzeigen (sollten).
Der Output funktioniert soweit (auch laut Oszilloskop), der Input zeigt mir jedoch eine konstante Spannung bei etwas mehr als 5,4V an.

Hat jemand eine Idee, warum ich am Input keinen Sinus angezeigt bekomme?
Anbei mein VI lv13_img.

Viele Grüße

Jens


Angehängte Datei(en)
13.0 .vi  test_ausgabe_eingabe.vi (Größe: 34,29 KB / Downloads: 6)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
05.09.2018, 15:09
Beitrag #2

jg Offline
CLD & CLED
LVF-Team

Beiträge: 15.216
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: DAQmx schreiben und lesen

Akzeptierte Lösung

Wähl mal den Erfassungsmodus "Reference Single Ended" bei der Datenerfassung und verbinde sicherheitshalber auch AO-GND mit AI-GND. Mglw. ist der Default-Modus Differential. Versuche auch, AI und AO zu synchronisieren. Aktuell kann es durchaus sein, dass dein AI-Task erst nach Beendung des AO-Tasks startet - oder umgekehrt.

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
06.09.2018, 09:36
Beitrag #3

Sakis Offline
LVF-Grünschnabel
*


Beiträge: 11
Registriert seit: Sep 2018

2013
-
DE


Deutschland
RE: DAQmx schreiben und lesen
Hallo Jens,

vielen Dank für deine Antwort. Durch das Umstellen des Erfassungsmodus auf RSE stellen und das Verbinden der beiden Ground Potentiale funktioniert es jetzt. Thanx

Gruß

Jens
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  lesen und schreiben am selben Gerät mit kritischem timing gottfried 4 792 12.12.2017 21:14
Letzter Beitrag: gottfried
  DAQmx schreiben mit NSamples Niwo 14 1.934 11.08.2017 13:29
Letzter Beitrag: GerdW
  line schreiben und nacher lesen ... wie geht das? gottfried 6 1.865 27.08.2014 16:28
Letzter Beitrag: jg
  Lesen/Schreiben (DAQmax) Zhara 12 5.462 26.02.2014 13:00
Letzter Beitrag: Zhara
  DAQ-Assistent ersetzen - DAQmx Lesen startet in Whileschleife immer neu daxel 16 8.482 16.08.2013 10:48
Letzter Beitrag: daxel
  Fehler -200429 beim schreiben / lesen M@rRy 12 5.328 08.09.2011 09:59
Letzter Beitrag: GerdW

Who read this thread?
1 User(s) read this thread:
Fraba

Gehe zu: