INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Ethernet Verbindung Steuerung geht mit Exe nicht



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

16.09.2020, 14:52
Beitrag #1

Stauche Offline
LVF-Neueinsteiger


Beiträge: 1
Registriert seit: Apr 2019

2017
2017
DE_EN



Ethernet Verbindung Steuerung geht mit Exe nicht
Moin,


Ich hab habe einen Prüfstand, in den Deditec-Relaiskarten eingebaut sind. Die Relais werden durch Nachrichten über die Ethernetschnittstelle geschaltet.

Wenn ich die Steuerung mit dem Laptop, auf dem es programmiert worden ist, ansteuere funktioniert alles. Auch die Exe funktioniert mit dem Laptop. Wenn ich die Exe allerdings auf dem dafür vorgesehenen Prüfrechner starte, bekommt er keine Verbindung zur Steuerung.

Die Treiber für die Steuerung sind alle installiert und ich kann auch über das Programm von Deditec auf die Steuerung zugreifen. Auch eine andere Deditecsteuerung, welche per USB angesteuert wird, kann mit dem
Prüfrechner angesteuert werden. NI-Visa, Labview Runtime, Ni-Daqmx sowie NI-XNet sind auf dem Prüfrechner installiert und entweder in der gleichen Version oder höher.


Hätte jemand noch ein paar Tipps wonach ich noch schauen könnte, damit ich das zum Laufen bekomme?
Könnte es an den unterschiedlichen Versionen liegen? Eigentlich sollten die doch abwärtskompatibel sein oder?


Vielen Dank schon mal für eure Hilfe

Gruß Christoph
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
16.09.2020, 14:57
Beitrag #2

GerdW Offline
______________
LVF-Team

Beiträge: 16.585
Registriert seit: May 2009

11SP1, 17SP1 (ab und zu 20)
1995
DE_EN

10×××
Deutschland
RE: Ethernet Verbindung Steuerung geht mit Exe nicht
Hallo Christoph,

Zitat:Hätte jemand noch ein paar Tipps wonach ich noch schauen könnte, damit ich das zum Laufen bekomme?
Hast du die IP-Einstellungen des LAN-Ports geprüft?
Hast du die Firewall-Einstellungen geprüft?
Hast du die Fehlermeldungen deiner VIs geprüft?

Zitat:Könnte es an den unterschiedlichen Versionen liegen? Eigentlich sollten die doch abwärtskompatibel sein oder?
Dazu hast du leider keinerlei Informationen gegeben: wie soll man dazu etwas substantielles beitragen?

Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
16.09.2020, 16:09 (Dieser Beitrag wurde zuletzt bearbeitet: 16.09.2020 16:10 von jg.)
Beitrag #3

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.585
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: Ethernet Verbindung Steuerung geht mit Exe nicht
Hallo Christoph,

Schuß ins Blaue: Passt die Bitness des Deditec-Treibers auf deinem Prüfrechner zur LabVIEW-Bitness?

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
16.09.2020, 16:46
Beitrag #4

Freddy Offline
Oldtimer
****


Beiträge: 703
Registriert seit: Aug 2008

2019, 2020, NXG 5.0
1996
DE

76275
Deutschland
RE: Ethernet Verbindung Steuerung geht mit Exe nicht
Hallo Christoph,
DEDITEC hat eigene Treiber für seine Module. Hast Du diese auch installiert?

Bei DEDITEC gibt's alles zum download.

Gruß
Freddy

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
30
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  CAN-Bus Ethernet Gateway n4f3ts 3 3.780 17.09.2015 13:15
Letzter Beitrag: n4f3ts
  VI zur Dekodierung von aufgezeichneten Ethernet-Frames (100BASE-TX) Ziggi 8 4.340 16.04.2013 06:56
Letzter Beitrag: Ziggi
  S7-300 über Ethernet parallel auslesen Hund am Strand 7 6.010 21.07.2012 11:31
Letzter Beitrag: Y-P
  Ethernet-Kommunikation mit SICK Ranger Kamera funktioniert nicht ahebauer 6 5.160 25.05.2012 08:33
Letzter Beitrag: ahebauer
  Ethernet Modul von KS Vario henviv 3 2.596 20.05.2012 10:07
Letzter Beitrag: rolfk
  Datenstream einer Ethernet-Schnittstelle abgreifen fheinrich 5 8.513 14.10.2011 12:16
Letzter Beitrag: ColdducK

Who read this thread?
9 User(s) read this thread:
Freddy, GerdW, jg, MScz, Stauche, kpa, th13, IchSelbst, Martin.Henz

Gehe zu: