INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Steuerung Schrittmotor Nanotec PD2-T57



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

27.01.2015, 13:48
Beitrag #1

matthias_os Offline
LVF-Neueinsteiger


Beiträge: 3
Registriert seit: Jan 2015

LV-2014
-
DE



Steuerung Schrittmotor Nanotec PD2-T57
Hallo Labviewforum-Gemeinde,

Ich habe Probleme bei der Ansteuerung des o.g. Motors mit Labview 2014.
Wir verwenden zur Ansteuerung des Motors das Digitalausgangsmodul NI9472.

Die Ansteuerung des Motors erfolgt bisher dadurch, dass dem Motor auf line 0 ein Richtungssignal 0 oder 1 gegeben wird,
während auf line 1 eine Folge von 1 und 0 übermittelt werden muss, wobei der Motor bei jeder fallenden Flanke in unserem Fall einen 1/10 Schritt macht.

Bei der Übermittlung des Taktes zeigen sich Probleme.
Senden wir mit dem DAQ-Assistenten ein Signal von Nullen und Einsen, das wir dem Assistenten über ein Cluster als Datenkonstante übermitteln, vollführt der Motor eine gleichmäßige Bewegung, die sich über die Paramter des Assistenten hinsichtlich der Geschwindigkeit problemlos einstellen lässt.
Wir lassen den DAQ-Assistenten in einer Whileschleife laufen und beenden die Datenübertragung über den Stoppparameter, wenn das Inkrement einen bestimmten Wert erreicht hat. Allerdings fährt der Motor hierbei die Positionen sehr ungenau an (Differenzen von mehreren cm!).

Alternativ habe ich dem Motor mit DAQmx write einen digitalen Datenverlauf oder eine einzelne boolsche Konstante übermittelt.
DAQmx write wird dabei in while-Schleife ausgeführt. Ich sende also immer wieder das selbe kurze digitale Signal aus Nullen und Einsen bzw. ein bollschen Wert der bei jeder Iteration negiert wird, also immer von true auf false und zurück wechselt.
Dabei fährt der Motor die Positon präzise an, die Bewegung erfolgt allerdings nicht gleichmäßig, der Motor stockt wiederholt.

Ich bin absoluter Labview-Neuling und wurde mit der Aufgabe betraut, den bereits verkabelten Motor zu bewegen.
Ich hoffe Ihr könnt mir erklären, was ich falsch mache oder wie ich grundlegend anders vorgehen muss.

Vielen Dank im vorraus.

Viele Grüße

Matthias
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
27.01.2015, 13:54 (Dieser Beitrag wurde zuletzt bearbeitet: 27.01.2015 13:54 von jg.)
Beitrag #2

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.589
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: Steuerung Schrittmotor Nanotec PD2-T57
Lad einmal dein VI hoch.

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
27.01.2015, 14:10
Beitrag #3

matthias_os Offline
LVF-Neueinsteiger


Beiträge: 3
Registriert seit: Jan 2015

LV-2014
-
DE



RE: Steuerung Schrittmotor Nanotec PD2-T57
Hallo Jens,

das VI "mit_assistent" wurde von Dritten erstellt
und darein möchte ich meine Ideen zur Datenübertragung später integrieren.

Die beiden anderen VI's sind meine Ideen aus try/error mit unterschiedlichen DAQmx write Einstellungen.


Angehängte Datei(en)
14.0 .vi  mit_assistent.vi (Größe: 224,31 KB / Downloads: 88)

14.0 .vi  mit_boolsch.vi (Größe: 17 KB / Downloads: 87)

14.0 .vi  mit_Datenverlauf.vi (Größe: 18,53 KB / Downloads: 69)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
28.01.2015, 10:56
Beitrag #4

matthias_os Offline
LVF-Neueinsteiger


Beiträge: 3
Registriert seit: Jan 2015

LV-2014
-
DE



RE: Steuerung Schrittmotor Nanotec PD2-T57
Ich habe in den Konfigurationen des DAQ-Assistenten mit dem Sígnalerzeugungsmodus
"endliche Anzahl" eine Möglichkeit gefunden meinen Motor flüssig und auch präzise einstellbar zu verfahren.
Ich führe den DAQ-Assistent nun nicht mehr mit kontinuierlicher Signalerzeugung in einer while-Schleife aus, bis das Inkrement einen bestimmten Wert erreicht, sondern lasse ihn einmalig eine endliche 0/1-Folge übermitteln.
Welche Möglichkeit gibt es dennoch die Signalübertragung abzubrechen, wenn der Motor z.B. auf einen Endschalter fährt?
Oder würdet ihr grundlegend anders vorgehen, um dem Motor einen Takt zu übermitteln mit genau bestimmbarer Anzahl fallender Flanken?
Ich schick noch ein VI mit, mit dem ich einfach nach rechts oder links fahren kann, außerdem werden am Anfang die Endschalter abgefragt.


Angehängte Datei(en)
14.0 .vi  Test.vi (Größe: 64,43 KB / Downloads: 101)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  Schrittmotor über PWM ansteuern Knödelmann 12 6.214 17.12.2015 10:43
Letzter Beitrag: GerdW
  Pulserzeugung für Schrittmotor könnes 2 2.755 17.02.2011 21:24
Letzter Beitrag: könnes
  Dynamisches Pulssignal für Schrittmotor Smoofo 0 2.858 03.11.2005 11:14
Letzter Beitrag: Smoofo

Gehe zu: