INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Mail mit Attachment



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

30.04.2024, 15:35
Beitrag #1

THL Offline
LVF-Gelegenheitsschreiber
**


Beiträge: 111
Registriert seit: May 2011

2012
2009
EN


Deutschland
Mail mit Attachment
Hallo,

ich würde gerne per LabView eine Mail mit Screenshot als Attachment senden. Es geht um die Überwachung einer Messung - falls ein Fehler auftritt, gibt's eine Mail mit Screenshot damit man schnell sieht, woran es hakt.

Leider kenne ich mich in Richtung Netzwerk/Mail so gar nicht aus und habe daher immer nach "Kochrezept" gearbeitet. Vor einigen Jahren hatte ich schonmal eine Routine geschrieben (woanders her kopiert^^), die auch damals™ gut funktionierte - siehe das erste Bild. Als ich die jetzt wieder testete, bekam ich allerdings die (für mich obskure) Fehlermeldung 1172 mit dem Text 'Die lokale Sicherheitsautorität (LSA) ist nicht erreichbar' (den Error-Handler im Bild habe ich auf die Schnelle reingehauen um zu sehen, was der genaue Fehler ist).

   

Das will nicht - ok, dann benutze ich eben die smtp-VIs, die LabView anbietet. Das Ergebnis ist im nachfolgenden Bild zu sehen.

   

Jetzt wird auch brav eine Mail versendet, allerdings nur solange ich *kein* Attachment anhänge. Sobald ich den Screenshot anhänge (eine JPG-Datei) wird die Mail vom Mailserver abgelehnt mit der Begründung 'message has lines too long for transport'. Ich vermute LabView bindet die Screenshot-Datei einfach als normale Textdatei ein, was natürlich schiefgeht.

Kann mir da jemand auf die Sprünge helfen, wie ich zum gewünschten Ziel komme?
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
30.04.2024, 21:53
Beitrag #2

Martin.Henz Offline
LVF-Team
LVF-Team

Beiträge: 423
Registriert seit: Jan 2005

2.5.1 bis 20
1992
kA

74363
Deutschland
RE: Mail mit Attachment
Hallo THL,

so auf den ersten Blick ist die .NET Version nicht so verkehrt. Ggf. bei MSDN nachlesen, was da genau zu tun ist. Etwas sehr komisch finde ich das VI das irgend etwas mit dem Passwort macht. Ich würde das weglassen, es sei denn es kommt am Ausgang auch tatsächlich das korrekte Passwort heraus.

Ein klein wenig einfacher gestrickt ist das hier:
https://forums.ni.com/t5/Example-Code/Se...-p/3509209

Martin Henz
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
01.05.2024, 10:30
Beitrag #3

THL Offline
LVF-Gelegenheitsschreiber
**


Beiträge: 111
Registriert seit: May 2011

2012
2009
EN


Deutschland
RE: Mail mit Attachment
Das mit dem Password ist schon ok so. Das ist eine Verschlüsselungs-/Entschlüsselungsroutine (Blowfish), die ich geschrieben habe, da die Login-Daten als Default in einer Datei gespeichert werden und dort das Password sinnigerweise verschlüsselt wird. Wird dann halt erst entschlüsselt, wenn es gebraucht wird. Und ja, es kommt auch das richtige Password raus (klappt ja auch bei meiner 2. Programmversion, wo ich dann andere Probleme habe...). Wo ich absolut auf dem Schlauch stehe, ist dass die erste Version ja damals (vor 2(?) Jahren) anstandslos funktioniert hat und jetzt aber diese für mich absolut unverständliche Fehlermeldung raushaut. Was bedeutet denn 'Die lokale Sicherheitsautorität (LSA) ist nicht erreichbar' ? Was ist damit überhaupt gemeint? Wie gesagt, in dieser Thematik kenne ich mich absolut Null aus.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
01.05.2024, 12:07
Beitrag #4

Martin.Henz Offline
LVF-Team
LVF-Team

Beiträge: 423
Registriert seit: Jan 2005

2.5.1 bis 20
1992
kA

74363
Deutschland
RE: Mail mit Attachment
Hi THL,

ach ja stimmt - diese Fehlermeldung gibt es ja auch noch.

Die Admins fragen. Sieht mir doch sehr nach etwas sehr lokalem aus, also etwas, was auf deinem PC passiert. Mit SMTP hat das nichts zu tun.

LSA = Local Security Authority
Einstellung bei Windows 11 mit: Windows-Sicherheit -> Gerätesicherheit -> Kernisolierung -> Speicherintegrität (einschalten oder ausschalten).

Warum das bei dem Mailversand Schwierigkeiten macht, das erschließt sich mir nicht.

Martin Henz
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  LV Tabelle per Mail versenden Tobi Wan Kenobi 2 3.454 13.08.2015 08:05
Letzter Beitrag: Lucki
  LabView DVDs eingelangt - mein Mail an NI gottfried 5 4.302 28.03.2013 11:15
Letzter Beitrag: jg
  Tabelle ins E-Mail einfügen TA6850 5 4.710 21.07.2008 17:28
Letzter Beitrag: OliverR

Gehe zu: