INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Dieses Thema hat akzeptierte Lösungen:

Open Protocol / TCP-IP / Atlas Copco



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

05.02.2020, 11:43
Beitrag #1

angry_Nameless Offline
LVF-Grünschnabel
*


Beiträge: 33
Registriert seit: Mar 2011

17.0.1
2011
DE

66424
Deutschland
Open Protocol / TCP-IP / Atlas Copco
Hallo zusammen,

ich bin mal wieder an dem Punkt angelangt, an dem ich Hilfe benötige.

Ich bin dabei einen Atlas Copco Schrauber mit dem PC auszulesen (Drehmomente etc.) Dazu verwendet Atlas Copco ihr eigenes Protokoll (Open protocol)
Ich habe die Kommunikation jetzt langsam im Griff, aber nun kommt mein Problem:

Ich muss auf dem TCP-Port "warten", bis ein Drehmoment vom Schrauber übermittelt wird. GLEICHZEITIG verlangt der Schrauber zum Offenhalten der Verbindung mindestens alle 10 Sekunden einen "Keep Alive"-Befehl.

Ich stehe gerade auf dem Schlauch, aber wie kann ich auf Daten warten und alle 10s etwas über die gleiche Verbindung senden?

Danke für eure Hilfe.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
05.02.2020, 12:09
Beitrag #2

Freddy Offline
LVF-Freak
****


Beiträge: 646
Registriert seit: Aug 2008

2018, 2019, NXG 3.1
1996
DE

76275
Deutschland
RE: Open Protocol / TCP-IP / Atlas Copco

Akzeptierte Lösung

Hallo angry,
beim lesen kann man eine Timeout festlegen. Setze den unter 10 Sec. nach dem Abbruch den Befehl schreiben und danach wieder lesen.

Gruß
Freddy

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
05.02.2020, 13:29 (Dieser Beitrag wurde zuletzt bearbeitet: 05.02.2020 13:30 von TpunktN.)
Beitrag #3

TpunktN Offline
LVF-Gelegenheitsschreiber
**


Beiträge: 64
Registriert seit: Jul 2011

2018
2011
DE

70***
Deutschland
RE: Open Protocol / TCP-IP / Atlas Copco
(05.02.2020 12:09 )Freddy schrieb:  beim lesen kann man eine Timeout festlegen. Setze den unter 10 Sec. nach dem Abbruch den Befehl schreiben und danach wieder lesen.

So mache ich das bei mir auch bei einer Messelektronik. Als Hinweis noch: der Fehler 56 kommt, wenn der Timeout das Lesen abbricht.
Hier die ganze Liste der Error Codes https://zone.ni.com/reference/en-XX/help...ror_codes/

"Auch aus Steinen, die einem in den Weg gelegt werden, kann man Schönes bauen."
Johann Wolfgang von Goethe
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
06.02.2020, 07:47
Beitrag #4

angry_Nameless Offline
LVF-Grünschnabel
*


Beiträge: 33
Registriert seit: Mar 2011

17.0.1
2011
DE

66424
Deutschland
RE: Open Protocol / TCP-IP / Atlas Copco
Hallo,

danke, so funktioniert es. Ich hatte es so ähnlich schon zusammengeklickt, wollte aber mal nachfragen, wie ihr es so löst.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  Dynamic Host Configuration Protocol erzeugen TiCy 2 3.084 07.05.2014 09:13
Letzter Beitrag: TiCy
  vector CAN Open Problem artia 4 4.485 20.02.2013 14:16
Letzter Beitrag: artia
  in EXE TCP open connection -> error 63 GT123 4 4.977 09.05.2012 10:16
Letzter Beitrag: GT123

Gehe zu: