INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Problem mit Datenverbindung zwischen HMI und Steuerung



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

14.11.2014, 08:42
Beitrag #1

LabviewLearning Offline
LVF-Grünschnabel
*


Beiträge: 20
Registriert seit: Jul 2014

13.0.1
2013
DE


Deutschland
Problem mit Datenverbindung zwischen HMI und Steuerung
Moin zusammen,

ich habe ein neues Problem bei der Verbindung zwischen der LabVIEW-HMI und der Beckhoff-Steuerung entdeckt.

Über DCOM kann ich die Daten zwischen HMI und SPS kommunizieren. Bei vergangenenTests mit anderem Steuerungspaket wurde die Datenverbindung schon mal erfolgreich funktioniert.

Ich habe ein neues Steuerungspaket in der Steuerung ersetzt. Die Datenverbindung funktioniert jetzt nicht mehr. In der HMI kriege ich die mit DataSocket-Pfads im OPC-Server angebundenen Items nicht mehr. DCOM-Verbindung funktioniert trotzdem noch, da ich die Items über Netzwerk anbinden konnte.

Aber danach wenn ich vom HMI-Rechner gleichzeitig eine Remotedesktopverbindung mit der Steuerung ausführe, kriege ich in der HMI die Werte wieder.

Ich weiß nicht, warum die Verbindung so funktioniert. Wo liegt mein Problem?

Ich hoffe, dass jemend im Forum mir weiter helfen könnte.

Viele Grüße,

LV_Learning
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
24.11.2014, 11:13
Beitrag #2

LabviewLearning Offline
LVF-Grünschnabel
*


Beiträge: 20
Registriert seit: Jul 2014

13.0.1
2013
DE


Deutschland
RE: Problem mit Datenverbindung zwischen HMI und Steuerung
Moin zusammen,

Update !!!

kann Kein jemand von Euch mir weiterhelfen ?

Ich brauche echt dringend Eure Unterstützung.

Viele Grüße,

LV_Learning
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
24.11.2014, 18:25
Beitrag #3

LabviewLearning Offline
LVF-Grünschnabel
*


Beiträge: 20
Registriert seit: Jul 2014

13.0.1
2013
DE


Deutschland
RE: Problem mit Datenverbindung zwischen HMI und Steuerung
Moin zusammen,

ich habe die Ursachen mein Problem gefunden aber leider keine Lösung dafür Sad(.

Bei der Steuerung habe ich für eine DCOM-Konfiguration noch einen anderen Rechnerbenutzer erstellt. Nach dem Neustarten oder Einschalten wird die Stererung automatisch unter diesem Benutzer eingeloggen. Bis jetzt funktioniert die Verbindung zwischen Steuerung und HMI noch einwandfrei.

Jetzt stelle ich eine Remotedesktopverbindung zur Steuerung von HMI. Nach der Abmeldung der Remotedesktopverbindung mit der Steuerung von HMI-Rechner wird Logoff Screensaver von Windows enstehen. Von hier habe ich keine Datenverbindung mehr. Bis die Steuerung unter meinem definierten Benutzer wieder eingeloggen wird, funktioniert meine Datenverbindun weiter.

D.h. wenn ich keine Remotedesktopverbindung mehr benutze, werde ich die Steuerung neustarten anstatt Remotedesktopverbindung trennen muss.

Meine Frage ist, wie man nach der Abschaltung der Remotedesktop verbindung wieder das unter definierten Benutzer eingeloggene Windows-Zustand kriegen kann. Ich weiß nicht, wie man bei Windows einstellen muss.

Ich hoffe, dass jemand mir eine Lösung für dieses Problem vorschlagen könnte.

Vielen Dank und viele Grüße,

LV_Learning
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  Problem zwischen LabVIEW und Beckhoff Twincat OPC Server LabviewLearning 1 2.954 26.09.2014 08:45
Letzter Beitrag: LabviewLearning

Gehe zu: