INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Probleme NI Usb 6501 DI/O



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

07.07.2009, 16:29
Beitrag #1

pauliprinzip Offline
LVF-Neueinsteiger


Beiträge: 8
Registriert seit: Jan 2009

8.6 studentenversion
2008
de

1150
Oesterreich
Probleme NI Usb 6501 DI/O
hallo allerseits


ich versuche die meßstellenposition meines meßstellenumschalters (burster 1630) auszulesen.

der burster 1630 hat 24 meßstellen und gibt diese über ein 14poliges kabel im bcd code aus.

er besitzt 4 ausgänge für die 1erstelle (1,2,4,8) und 2 für die 10erstelle (1,2). die restlichen leitungen sind ein eingang und mehrere auf 0 und 5 volt.

beim auslesen der meßstelle liegen entweder 0 oder 5 volt an den entsprechenden 6 leitungen an.

mein gedanke war mit diesen 6 leitungen ins di/o gerät zu gehen und die meßstellenposition auszulesen, nur reagiert das ni gerät nicht auf die 0 volt des burster.

egal auf welcher position ich bin zeigt mir das m&a testpanel keine änderung an.

mit dem ground des ni 6501 kurzgeschlossen reagieren die eingänge sofort.


woran könnte das liegen???

danke

glg
walter
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
07.07.2009, 18:40
Beitrag #2

Y-P Offline
☻ᴥᴥᴥ☻ᴥᴥᴥ☻
LVF-Team

Beiträge: 12.612
Registriert seit: Feb 2006

Developer Suite Core -> LabVIEW 2015 Prof.
2006
EN

71083
Deutschland
Probleme NI Usb 6501 DI/O
Hast Du die Ausgänge an eine Digital-I/O-Karte von NI verbunden und willst die Werte nun einlesen?
Dann dürfte es gar kein Problem mehr sein?

Aber was meinst Du damit? Bahn

' schrieb:nur reagiert das ni gerät nicht auf die 0 volt des burster.
[...]
mit dem ground des ni 6501 kurzgeschlossen reagieren die eingänge sofort

Hast Du es schon als VI versucht, oder nur im MAX?

Gruß Markus

--------------------------------------------------------------------------
Bitte stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort !!
--------------------------------------------------------------------------
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
07.07.2009, 20:24
Beitrag #3

pauliprinzip Offline
LVF-Neueinsteiger


Beiträge: 8
Registriert seit: Jan 2009

8.6 studentenversion
2008
de

1150
Oesterreich
Probleme NI Usb 6501 DI/O
hallo markus

danke für die antwort.

habe mich wohl etwas missverständlich ausgedrückt.

ja ich habe die ausgänge des burster an den ni usb 6501 angeschlossen.

sowohl der burster als auch ni usb 6501 di/o arbeiten mit 0 volt und 5 volt, wobei der burster um paar prozent abweicht, was aber laut datenblatt ni usb 6501 kein problem sein sollte.

wenn ich den ground vom ni 6501 mit einem eingang kurzschließe ändert sich der zustand des einganges laut max und dem interactive Control Panel for USB-6501(ist eine vi).

der burster gibt ebenfalls 0 volt oder 5 volt aus, also meiner meinung sollte der usb 6501 bei 0 volt auf einer der 6 burster zuleitungen reagieren, uns zwar genauso wie beim kurzschluss mit ground.

geschieht aber nicht?????

liebe grüße

walter
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
08.07.2009, 06:19
Beitrag #4

Y-P Offline
☻ᴥᴥᴥ☻ᴥᴥᴥ☻
LVF-Team

Beiträge: 12.612
Registriert seit: Feb 2006

Developer Suite Core -> LabVIEW 2015 Prof.
2006
EN

71083
Deutschland
Probleme NI Usb 6501 DI/O
Hast Du es schon mit Pull-Down-Widerständen,... versucht um einen definierten Pegel zu bekommen?

Gruß Markus

--------------------------------------------------------------------------
Bitte stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort !!
--------------------------------------------------------------------------
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  NI USB 6501 mit LabVIEW oder Visual Studio verbinden peterbe 6 5.895 22.07.2014 22:12
Letzter Beitrag: jg
  USB-6501 alfie_2303 1 2.775 26.11.2013 17:19
Letzter Beitrag: jg
  NI-USB 6501: Eingänge zeigen unbeschaltet High-Pegel kwakz 7 4.384 19.08.2013 13:32
Letzter Beitrag: Clyde
  Datenerfassung mit NI USB-6501 Himalaya 7 5.808 20.01.2011 11:55
Letzter Beitrag: Himalaya
  USB 6501 schaltet falschen/anderen Digitalausgang raeuberfisch 3 3.371 07.09.2010 10:50
Letzter Beitrag: jg
  USB-6501 bei Rechnerstart sind alle Ausgänge auf high(TTL) toaran_ 5 5.697 17.02.2009 11:41
Letzter Beitrag: rolfk

Gehe zu: