INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Probleme bei der Datenerfassung eines Drehzahlgebers



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

11.03.2020, 15:54 (Dieser Beitrag wurde zuletzt bearbeitet: 11.03.2020 20:56 von GerdW.)
Beitrag #1

Pr3g0 Offline
LVF-Neueinsteiger


Beiträge: 2
Registriert seit: Mar 2020

2018
2019
DE



Probleme bei der Datenerfassung eines Drehzahlgebers
Guten Tag,

Ich bin Labview Neuling und versuche mich gerade an einem Messsystem über Labview mit dem es möglich ist diverse Kenndaten von Motoren aufzunehmen.
Leider funktioniert es mit dem Drehzahlgeber nicht so ganz.Blink
als Messaufnehmer wird ein näherungsschalter mit 3Khz Schaltfrequenz verwendet dieser geht direkt auf die Messkarte (Redlab 1408)
Da an dem motor 6 Schrauben befestigt sind bekomme ich pro umdrehung 6 Flanken.
Angezeigt werden aber nur undefinierbare ausschläge??
oben angeheftet ist mein vorläufiges Programm es wäre schön wenn jemand mal drüberschaut vielleicht sieht man ja meinen Fehler schon?
vielen dank im voraus2hands
   
Edit: Attachments immer hier im Forum anhängen!
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
11.03.2020, 20:59
Beitrag #2

GerdW Offline
______________
LVF-Team

Beiträge: 16.301
Registriert seit: May 2009

11SP1, 17SP1 (ab und zu 19)
1995
DE_EN

10×××
Deutschland
RE: Probleme bei der Datenerfassung eines Drehzahlgebers
Hallo Pr,

herzlich willkommen im Forum!

Ich habe deinen Beitrag editiert: Bilder und andere Anhänge immer hier im Forum anhängen!

Zum Bild:
Gibt es irgendeinen Grund, warum du die DAQ-Tasks in jeder Iteration erneut anlegen musst? Und dann auch gleich wieder killen musst?
Warum arbeitest du mit "Finiten" Tasks, wenn du fortdauernde Messungen vornehmen willst?

Und überhaupt: Bilder lassen sich mit LabVIEW nicht editieren/debuggen…

Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
18.03.2020, 11:06
Beitrag #3

Pr3g0 Offline
LVF-Neueinsteiger


Beiträge: 2
Registriert seit: Mar 2020

2018
2019
DE



RE: Probleme bei der Datenerfassung eines Drehzahlgebers
Danke für deine Antwort,

Das ist mein erster versuch für ein Labview Programm einen genauen grund für das neue anlegen der DAQ Task gibt es nicht
es hat einfach beim Messen der Spannung und des Stromes funktioniert wie es jetzt ist.
Die "finiten" tasks sind warscheinlich bei einer Drehzahlmessung falsch da ich ja sonst nur einmalig den Zustand der Flankein der Schleife Messe
und somit falsche Werte entstehen könnenUndecided

Leider misst der Drehzahlpfad immernoch undefinierbare Werte und ich weiß wirklich nicht mehr weiter.
Das Programm ist jetzt hoffentlich im Anhang es wäre wunderbar wenn es jemand debuggen könnte und mir meine fehler zeigt.

Danke schonmal


15.0 .vi  GUI1.vi (Größe: 188,74 KB / Downloads: 6)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
18.03.2020, 11:23
Beitrag #4

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.495
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: Probleme bei der Datenerfassung eines Drehzahlgebers
(18.03.2020 11:06 )Pr3g0 schrieb:  Die "finiten" tasks sind warscheinlich bei einer Drehzahlmessung falsch da ich ja sonst nur einmalig den Zustand der Flankein der Schleife Messe
und somit falsche Werte entstehen könnenUndecided
Vollkommen richtig erkannt - bitte ändern und vorher nicht wundern, dass du "Blödsinn" misst.

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
18.03.2020, 13:18 (Dieser Beitrag wurde zuletzt bearbeitet: 18.03.2020 13:18 von GerdW.)
Beitrag #5

GerdW Offline
______________
LVF-Team

Beiträge: 16.301
Registriert seit: May 2009

11SP1, 17SP1 (ab und zu 19)
1995
DE_EN

10×××
Deutschland
RE: Probleme bei der Datenerfassung eines Drehzahlgebers
Hallo Pr,

Zitat:Leider misst der Drehzahlpfad immernoch undefinierbare Werte und ich weiß wirklich nicht mehr weiter.
Das Programm ist jetzt hoffentlich im Anhang es wäre wunderbar wenn es jemand debuggen könnte und mir meine fehler zeigt.
Du legst die Tasks innerhalb der (inneren) Schleife immer neu an und löscht sie dann gleich wieder: sowas macht man nicht!
Einmal vor der Schleife anlegen und einmal nach der Schleife beenden!
(Aufräumen schadet auch nicht.)

Zum Drehzahl-Task (auch wenn nicht nicht mit der ULx arbeite):
Du legst einen finiten Task mit "1 Sample per channel" an - und willst dann "1chan N samples" lesen: was soll das bringen?

Was bekommst du denn für Werte? Kannst du mal gemessene Daten bereitstellen?

Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  Datenerfassung cDAQ + NI9203 keine synchrone Datenerfassung dieseldunst 5 2.787 24.06.2016 14:49
Letzter Beitrag: jg
  Probleme Datenerfassung Abtastwerte nicht erfasst Samel 2 2.457 09.08.2013 10:05
Letzter Beitrag: Samel
  Probleme beim gleichzeitigen Ein- und Auslesen eines Sinussignals mit myDAQ SuperMaWio 4 4.304 09.03.2011 00:03
Letzter Beitrag: kpalime
  Datenerfassung eines 2-Taktmotors Junikind75 18 7.861 19.07.2010 11:11
Letzter Beitrag: s.rockel
  Probleme mit DAQmx-Datenerfassung oswald1 7 6.027 17.11.2009 07:34
Letzter Beitrag: Y-P
  Akute Probleme bei Datenerfassung über zwei Kanäle halle76 4 2.771 22.01.2009 13:29
Letzter Beitrag: halle76

Gehe zu: