INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Rauschen bei diff. Analogerfassung mit cDAQ 9189/ NI 9205



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

31.10.2018, 08:49
Beitrag #1

Sundriver Offline
LVF-Neueinsteiger


Beiträge: 3
Registriert seit: Oct 2018

2017
2015
DE



Rauschen bei diff. Analogerfassung mit cDAQ 9189/ NI 9205
Hallo Liebe Community,

nachdem das Forum mir in den letzten Jahren bereits bei all meinen Fragen/Problemen weiterhelfen konnte, bin ich nun an einem Punkt angekommen, wo ich euch einmal direkt um Rat fragen möchte.

Zu meinem Problem: Ich habe einen Drucksensor Typ CTEM8000 (0-10 V, absolut, https://www.first-sensor.com/cms/upload/..._11508.pdf ),
welchen ich über ein cDAQ 9189 mit NI 9205-Modul differentiell auslese (Anschluss siehe Skizze). Das klappt auch schon seit einiger Zeit ohne Probleme.
Das Signal war immer leicht verrauscht, im Bereich +/- 10 mV, bisher hat das bei stationären Untersuchung aber nicht gestört, da ich einfach über eine entsprechende Anzahl gemittelt habe.

Nun möchte ich die Sensoren aber auch verwenden um instationäre Strömungsvorgänge zu erfassen und möchte das Messrauschen (hardwareseitig) minimieren.
Habe die Verkabelung überarbeitet, alle Leitungen abgeschirmt und soweit möglich räumlich von den Netzleitungen (230 V) getrennt.
Ergebnis ist ein leicht verringertes Rauschen (+/- 7 mV), was mich aber immer noch nicht zufrieden stellt.
Meine Vermutung: Das schon häufig thematisierte Problem mit der Erdung/Masse liegt auch bei mir vor. Leider haben mir google und das LV-Forum bisher nur bedingt weitergeholfen.
Deswegen meine Bitte an euch: Würdet ihr meine Verkabelung (siehe Skizze) einmal kurz checken und mir Rückmeldung geben, ob ich tatsächlich grob was falsch verkabelt habe?

Danke im Voraus. Falls ihr noch weitere Infos braucht, kurz Bescheid geben.
Gruß,
Tobi
       
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
31.10.2018, 09:26 (Dieser Beitrag wurde zuletzt bearbeitet: 31.10.2018 09:33 von Lucki.)
Beitrag #2

Lucki Offline
Tech.Exp.2.Klasse
LVF-Team

Beiträge: 7.632
Registriert seit: Mar 2006

LV 2015-17 prof.
1995
DE

01108
Deutschland
RE: Rauschen bei diff. Analogerfassung mit cDAQ 9189/ NI 9205
Wichtig ist: In der Minus-Messleitung zwischen dem CTE800 und A18 sollte keinerlei Strom fließen dürfen. Also von -Vs aus zwei Leitungen ziehen: eine von -Vs nach A18 uund eine -Vs nach COM. Abschirmung auch an -Vs legen.
   
PS: In Deiner Skizze gibt es 4 "Lötstellen im freien Raum". Ich glaube nicht, dass das in der Realität so ist. Die Details der Verdrahtung könnten aber wichtig sein, um hier etwas beurteilen zu können!
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
31.10.2018, 10:25
Beitrag #3

Sundriver Offline
LVF-Neueinsteiger


Beiträge: 3
Registriert seit: Oct 2018

2017
2015
DE



RE: Rauschen bei diff. Analogerfassung mit cDAQ 9189/ NI 9205
Hallo Lucki,

danke schon einmal für deine Hilfe.
Getrennte Leitungen habe ich bereits. Das Sensorausgangskabel habe ich an eine Mehrstock-Reihenklemme angeschlossen, an die widerum die -Vs-Spannungsversorgung, die Leitung zu AI8 und die Leitung zu COM angeschlossen sind.

Mit der Abschirmung an -Vs meinst du da Sensorabschirmung, Kabelabschirmung oder beides?

Wegen den freien Lötstellen: Die gibt es tatsächlich nicht. Auch für die beiden blauen +Vs-Verbindungen habe ich jeweils ein Kabel über eine Mehrstockklemme gelegt.
Verzeihung für die Ungenauigkeit.

Gruß,
Tobi
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
01.11.2018, 11:35 (Dieser Beitrag wurde zuletzt bearbeitet: 01.11.2018 12:14 von HVo.)
Beitrag #4

HVo Offline
Erbsenzähler
*


Beiträge: 31
Registriert seit: Oct 2008

>3.1 :)
1992
EN

38000
Deutschland
RE: Rauschen bei diff. Analogerfassung mit cDAQ 9189/ NI 9205
Sensor noise ist mit 0,1%FSO spezifiziert, bei 10V sind das schon deine 10mV ... aber ob das Vrms sind?

Da Du eine Kopplung über die gemeinsame V- Sensorleitung nicht vermeiden kannst, sollte dieses Kabel möglichst kurz sein. (Aber besser etwas länger und weg von mag. Kopplungen...) falls also noch 1m aufgerollt vor der Klemme liegen... Wink

Die diff. Zuleitung zum 9205 sollte verdrillt sein. Schirmung nur einseitig anschließen

Kenne Deinen Feind: Mit maximaler Abstastrate Messungen machen und mal die FFT ansehen.

Gruß Henrik

Tschuess
Henrik

---
'The number you have dialed is imaginary, please turn your phone 90° and dial again....'
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
10.11.2018, 10:42
Beitrag #5

Sundriver Offline
LVF-Neueinsteiger


Beiträge: 3
Registriert seit: Oct 2018

2017
2015
DE



RE: Rauschen bei diff. Analogerfassung mit cDAQ 9189/ NI 9205
Hallo,

vielen Dank für eure Tipps. Hab das meiste davon in die Tat umgesetzt.
Leider mit geringem Erfolg. Der Punkt war wahrscheinlich wirklich die 0,1% Sensor Noise.
Hab jetzt einen anderen Sensor verwendet, der im für mich relevanten Bereich weniger rauscht.
Eure Ideen waren aber auf jedenfall für zukünftige Projekte sehr hilfreich, deswegen hier nochmal mein ausdrücklicher Dank.

Gruß,
Tobi
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
30
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  cDAQ und DAQ Gerätetemperatur auslesen. erzengelsamael 7 978 22.10.2018 10:42
Letzter Beitrag: erzengelsamael
  Automatische Erkennung von cDAQ Modulen zt300 4 1.441 09.01.2018 07:38
Letzter Beitrag: zt300
  Filtern von Rauschen Felifa 10 2.721 30.03.2017 11:50
Letzter Beitrag: Felifa
  Komplexes Programm mit cDAQ MR_Engineer 5 1.334 16.03.2017 08:15
Letzter Beitrag: jg
Question Herausfinden ob cDAQ in Benutzung achim @ FZK 2 1.642 21.02.2017 08:36
Letzter Beitrag: achim @ FZK
  Entwicklungsumgebung beeinflusst cDAQ in Runtime Nordvestlys 2 1.899 12.10.2016 13:06
Letzter Beitrag: Nordvestlys

Who read this thread?
6 User(s) read this thread:
Ralfk84, Zadomo, Freddy, Lucki, Achim, BNT

Gehe zu: