INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

SMCI 33 -1 Motorsteuerung



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

21.08.2019, 07:39
Beitrag #1

Jugien83 Offline
LVF-Neueinsteiger


Beiträge: 4
Registriert seit: Aug 2019

2018
-
DE



SMCI 33 -1 Motorsteuerung
Hallo,

ich bin ein absoluter Anfänger bei LabVIEW. Ich bin dabei eine Motorsteuerung aus einem bestehenden VI zu modifizieren. Dabei geht es, dass der Motor eine Gewindestange antreibt und ein Polariskop sich mitbewegt. Mein Problem besteht darin, dass ich die Feineistellung nicht hinkriege. Der Motor soll nach rechts und links (vor- und zurücktippen z.B. 1mm) sich drehen sodass die Gewindestange sich mitdreht und er soll die Position anzeigen wo er sich gerade befindet. Momentan ist es so, dass sich die Motorsteuerung zwar nach links und rechts sich bewegen lässt aber ich jedesmal den Error Reset betätigen muss damit es weitergehen kann und somit die Positionsanzeige jedesmal auf 0 gesetzt wird. ich wäre für jede Hilfe sehr dankbar. Das VI füge ich bei.


Angehängte Datei(en)
18.0 .vi  Nanotec-Example mit Tippeigenschaft.vi (Größe: 5,18 MB / Downloads: 16)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
22.08.2019, 14:09
Beitrag #2

MaxP Offline
LVF-Gelegenheitsschreiber
**


Beiträge: 71
Registriert seit: Oct 2016

LV Prof. SSP
-
DE_EN


Deutschland
RE: SMCI 33 -1 Motorsteuerung
Hallo Jugien83,

erst mal würde ich dein VI aufräumen und ein paar Kommentare reinsetzen was wo passiert. Dann kann man dir auch besser helfen.
Daneben würde ich auch noch mehr SubVIs bauen, die man später einfacher wieder verwenden kann. Die Case Strukturen könntest du dir bei der Verwendung eines Qeued Message Handlers auch komplett sparen.

Zu deinem Problem: Wenn du den Regler nur mit einem Fehlerreset wieder ans Laufen bekommst, solltest du schauen, wo der Fehler herkommt und was der Regler dir für einen Fehler meldet. Oft sind es halt Kleinigkeiten wie falsche Parameter oder aber der falsche Befehl.

Gruß Max

PS: Hast du mal ein Handbuch zu dem Regler? Auf die schnelle konnte ich keine Befehlsübersicht zu dem Regler finden.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
23.08.2019, 06:45 (Dieser Beitrag wurde zuletzt bearbeitet: 23.08.2019 06:47 von Jugien83.)
Beitrag #3

Jugien83 Offline
LVF-Neueinsteiger


Beiträge: 4
Registriert seit: Aug 2019

2018
-
DE



RE: SMCI 33 -1 Motorsteuerung
Hallo Max,

danke für deine Tipps. Ich habe das VI etwas übersichtlicher gemacht und geschafft, dass der Takt (das Tippen) jetzt funktioniert aber momentan nur nach rechts. Damit er in die andere Richtung funktioniert muss ich die Befehlsfolge "p1" und "s200" tauschen.

VG

Jugien
das optimierte VI habe ich beigefügt.

VG

Jugien


Angehängte Datei(en)
18.0 .vi  Nanotec-Example mit Tippeigenschaft.vi (Größe: 5,18 MB / Downloads: 6)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
26.08.2019, 06:49
Beitrag #4

Jugien83 Offline
LVF-Neueinsteiger


Beiträge: 4
Registriert seit: Aug 2019

2018
-
DE



RE: SMCI 33 -1 Motorsteuerung
hier ist das Programmierhandbuch.

VG

Jugien


Angehängte Datei(en)
0.0 .pdf  Programmierhandbuch_V2.7.pdf (Größe: 1,48 MB / Downloads: 13)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
26.08.2019, 10:53
Beitrag #5

Jugien83 Offline
LVF-Neueinsteiger


Beiträge: 4
Registriert seit: Aug 2019

2018
-
DE



RE: SMCI 33 -1 Motorsteuerung
Hallo,

ich habe es hinbekommen. Der Fehler war ziemlich simpel, ich habe nur in dem Case Structure für die Taktgebung Links und Rechts die Read VI durch die Write Read VI ersetzt und nun funktioniert alles wie es soll.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
30
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  Motorsteuerung Nanotec mittels VCP HansHenning 12 3.067 18.05.2018 16:50
Letzter Beitrag: GerdW
  Einfache Motorsteuerung virtuell darstellen Kernfusion 3 4.841 23.10.2013 08:21
Letzter Beitrag: Firedevil87
  Motorsteuerung Sebastiansmyk 3 5.362 13.03.2012 22:28
Letzter Beitrag: Tschirno
  Einfache Motorsteuerung (Hilfe bitte) Sternenwanderer 1 3.673 06.02.2012 17:30
Letzter Beitrag: GerdW
  Realisierung einer Motorsteuerung mit RS485 Bus Pokerface 2 3.682 20.04.2011 10:51
Letzter Beitrag: IchSelbst
  Grundfragen zur Motorsteuerung Jansen83 0 1.822 14.05.2009 13:19
Letzter Beitrag: Jansen83

Who read this thread?
1 User(s) read this thread:
Jugien83

Gehe zu: