INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

SubVI mit DLL Call fehlt in exe



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

29.08.2019, 14:39 (Dieser Beitrag wurde zuletzt bearbeitet: 29.08.2019 14:40 von NoWay.)
Beitrag #1

NoWay Offline
LVF-Gelegenheitsschreiber
**


Beiträge: 206
Registriert seit: Jul 2013

2018, 2019
2013
EN


Deutschland
SubVI mit DLL Call fehlt in exe
Hallo zusammen.

Wir verwenden bei uns Präzisionsspannungsquellen von Burster, konkret Modell 4462.
Die Firma stellt keine direkten VIs bereit, sondern ein lib file sowie eine passende DLL. Diese Daten habe ich dann via Labview importiert und daraus einzelne VIs generiert. Das ging alles automatisch.
Im Anschluss habe ich mir aus den einzelnen VIs ein einzelnes VI gebaut (4462_SetValues.vi, siehe Anhang), das lediglich eine Spannungsvorgabe an das Netzteil schickt. Hat alles wunderbar funktioniert...auf meinem Rechner.

Nun habe ich daraus eine Exe generiert und es an zwei Kollegen weitergegeben. Der eine Kollege bekommt beim Start des Programms das Hauptfenster angezeigt, das Programm selbst steht jedoch still. der gebrochene Pfeil ist oben links in der Leiste zu sehen. Klickt er drauf, bekommt er die Meldung das die drei VI´die jeweils einen DLL Aufruf enthalten und aus der Lib geniert wurden, nicht gefunden werden können.

Bei dem zweiten Kollegen, der die Subvis ebenfalls nie auf dem Rechner hatte, läuft das kompilierte Programm allerdings fehlerfrei.
Darauf hin habe ich den Application Builder nach Hinweisen durchforstet, die dieses Phänomen irgendwie erklären können. Nichts...soweit ich das jedenfalls beurteilen kann.
Ich habe die DLL Aufrufe überprüft. Die referenzierte DLL liegt im Projektverzeichnis und wird im AppBuilder als always included mit in das Supportdirectory (\Data) kopiert.

Ich hänge hier jetzt einmal die generierten VIs an plus das, was ich daraus erstellt habe.
Desweiteren hier die Fehlermeldung des Kollegen:
   

Ich verstehe nicht, wieso die VIs bei ihm nicht gefunden werden und bei einem anderen Kollegen schon.

Kann irgendjemand von euch mit diesen Schilderungen etwas anfangen oder hat ein ähnliches Phänomen in der Vergangenheit beheben können?

***EDIT***
Ich reiche auf Wunsch ältere Versionen der Lib nach. Aktuell Bedarf es LabVIEW 2019.

Beste Grüße
NoWay


Angehängte Datei(en)
0.0 .zip  Burster4462.zip (Größe: 484,32 KB / Downloads: 9)

19.0 .vi  4462_SetValue.vi (Größe: 13,91 KB / Downloads: 9)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
30.08.2019, 13:15
Beitrag #2

Freddy Offline
LVF-Freak
****


Beiträge: 616
Registriert seit: Aug 2008

2018, 2019, NXG 2.0 BETA
1996
DE

76275
Deutschland
RE: SubVI mit DLL Call fehlt in exe
Hallo NoWay,
beim BURSTER BP4462 muss die bP4462.dll mit geliefert werden.
Es genügt, wenn sie in dem erweiterten Ordner data enthalten ist.
Ich binde es gleich in den Installer mit ein.

Gruß
Freddy


Angehängte Datei(en) Thumbnail(s)
   

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Webseite des Benutzers besuchen Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  relativ Pfad für Call Library Function GT123 4 3.780 05.11.2012 16:18
Letzter Beitrag: rolfk
  Registerkarte "Callbacks" im Call Library Function Node. wernerIBN 4 4.469 01.12.2010 14:24
Letzter Beitrag: wernerIBN
  Call Libary Function Node pannchen 3 6.082 06.04.2009 08:11
Letzter Beitrag: pannchen
  Parameterübergabe beim Call DLL Functions inLabVIEW pericles 9 5.596 03.03.2009 09:47
Letzter Beitrag: pericles
  .dll für ältere USB Camera einbinden .h fehlt silvio2323 14 8.033 15.05.2008 15:45
Letzter Beitrag: silvio2323
  Call Library Function Node fk08 3 6.289 19.03.2008 11:41
Letzter Beitrag: s200rs

Who read this thread?
1 User(s) read this thread:
rolfk

Gehe zu: