INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

VISA-Read-Fehler-1073807339



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

09.12.2014, 17:27
Beitrag #1

eyk107 Offline
LVF-Grünschnabel
*


Beiträge: 41
Registriert seit: Aug 2013

2014
-
DE


Deutschland
VISA-Read-Fehler-1073807339
Mal wieder hallo an alle,

nach Acht vergeblichen Stunden Fehlersuche hoffe ich das mir hier jemand weiterhelfen kann bzw. vllt eine Idee hat.
Zum derzeitigen Stand:
Ich habe ein VNA-Board von Anritsu über USB an meinen Rechner angeschlossen. Des Weiteren benötige ich ein dazugehöriges Programm das im Hintergrund läuft. Die Vorgabe des Programmes ist es, das Remotebefehle die an die Karte geschickt werden, an die IP 127.0.0.1 gesendet werden. Das Programm holt sich diese und leitet diese dann weiter. Ich hoffe das man das nachvollziehen kann.
Die IP habe ich unter Netzwerk in NI MAX hinzugefügt damit ich eine VISA-Session zur Kommunikation öffnen kann. Unter NI MAX funktionieren Befehle dann auch Problemlos (z.B. IDN?)
Nun zu meinen Problem: Wenn ich mit dem VNA Messwerte in Labview aufnehmen möchte, packe ich den dazugehörigen Befehl in eine While-Schleife mit einer Wartezeit. Meine Whileschleife beendet sich, sobald ein Fehler auftritt. Nach einer beliebigen Anzahl an Durchläufen (mal 8, dann 13, oder 23. Einmal sogar 93) beendet sich dann die Whileschleife aufgrund des Fehlers-1073807339. Jetzt lässt sich über Visa kein "Read-Befehl" mehr in Labview noch in NI MAX ausführen. Damit ich das vi wieder ausführen kann muss erst Labview und das Programm im Hintergrund komplett neu gestartet werden. Ich hoffe ich habe das Problem halbwegs erklären können, und jemand hat noch eine Idee was man einstellen oder probieren könnte. Den Programmcode kann ich leider nicht hochladen, er enthält aber auch nur SCPI-Befehle.
Danke schon mal für eure Hilfe.

Mfg Eyk

P.S.: Den Support habe ich auch schon kontaktiert, allerdings dauert es dort immer etwas länger.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
09.12.2014, 17:45
Beitrag #2

GerdW Offline
______________
LVF-Team

Beiträge: 16.382
Registriert seit: May 2009

11SP1, 17SP1 (ab und zu 19)
1995
DE_EN

10×××
Deutschland
RE: VISA-Read-Fehler-1073807339
Hallo eyk,

das ist der ganz normale TimeOut-Fehler (BFFF0015), der auftritt, wenn vom Gerät keine Antwort mehr zurückkommt…

Reagiert der VNA nicht mehr auf Befehle? Kannst du den (notfalls händisch) in einem solchen Fall resetten?

Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
09.12.2014, 17:54
Beitrag #3

eyk107 Offline
LVF-Grünschnabel
*


Beiträge: 41
Registriert seit: Aug 2013

2014
-
DE


Deutschland
RE: VISA-Read-Fehler-1073807339
Ich kann leider nicht testen ob der VNA nicht mehr auf Befehle reagiert da es sich nur um ein Board mit Spannungsversorgung, USB-Eingang und zwei SMA-anschlüssen handelt. Ich habe auch schon den "CLR Befehl" und den "VISA I/O Buffer entleeren" Befehl in jeden Schleifendurchlauf gesetzt, in der Annahme, dass mir der Speicher irgendwo vollläuft. Allerdings ohne Besserung. Im Taskmanager ist auch nichts unauffälliges in Hinsicht auf Speicher- oder CPU-Auslastung zu sehen.
Idee von meiner Seite: Wenn ich auf die IP-Adresse 127.0.0.1 eine VISA-Session öffne, ist diese doch "blockiert", und es kann doch kein anderes Programm auf diese zugreifen und meine Kommunikation behindern oder?

Mfg
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
09.12.2014, 19:51
Beitrag #4

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.532
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: VISA-Read-Fehler-1073807339
Interessantes Konzept, eine VISA-Session auf die IP "localhost" (also den eigenen Rechner) zu öffnen. Hmm
Hast du es schon mit TCP/IP-Open + TCP Read/Write auf localhost probiert?

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
09.12.2014, 20:48
Beitrag #5

eyk107 Offline
LVF-Grünschnabel
*


Beiträge: 41
Registriert seit: Aug 2013

2014
-
DE


Deutschland
RE: VISA-Read-Fehler-1073807339
Ach hör bloß auf. Hab mich schon so oft über die Verwendung des bootloops aufgeregt obwohl man direkt an usb hängt. Es hängt wahrscheinlich damit zusammen, da das board sonst irgendwo im Gehäuse mit usb, rj45 und gpib sitzt.

Aber noch garnicht dran gedacht, werde ich morgen auf Arbeit mal probieren. Bin nur verwundert, da der Fehler zwar reproduzierbar ist, aber immer zu unterschiedlichen Zeitpunkten auftritt. Vllt antwortet ja der Support noch in diesem Jahr.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
09.12.2014, 22:18
Beitrag #6

jg Offline
CLA & CLED
LVF-Team

Beiträge: 15.532
Registriert seit: Jun 2005

20xx / 8.x
1999
EN

Franken...
Deutschland
RE: VISA-Read-Fehler-1073807339
Nicht dass das jetzt falsch verstanden wird:
TCP/IP über VISA hat durchaus seine Berechtigung (z.B. um einen einheitlichen Gerätetreiber für verschiedene Schnittstellen zu erstellen) und funktioniert in der Regel auch gut.

Die Idee mit TCP/IP direkt wollte ich herausstellen, da du dich "mit dir selbst" verbindest - wenn ich richtig verstehe, dann mit dem "Hintergrund"-Programm. Vielleicht lässt sich in diesem Fall eine echte TCP/IP Session besser schließen als eine VISA-Session.
(09.12.2014 20:48 )eyk107 schrieb:  Ach hör bloß auf. Hab mich schon so oft über die Verwendung des bootloops aufgeregt obwohl man direkt an usb hängt. Es hängt wahrscheinlich damit zusammen, da das board sonst irgendwo im Gehäuse mit usb, rj45 und gpib sitzt.
Aha, das VNA (welches eigentlich genau?) hat RJ45, am Ende sogar eine TCP/IP-Schnittstelle?

Gruß, Jens

Wer die erhabene Weisheit der Mathematik tadelt, nährt sich von Verwirrung. (Leonardo da Vinci)

!! BITTE !! stellt mir keine Fragen über PM, dafür ist das Forum da - andere haben vielleicht auch Interesse an der Antwort!

Einführende Links zu LabVIEW, s. GerdWs Signatur.
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
10.12.2014, 08:39
Beitrag #7

eyk107 Offline
LVF-Grünschnabel
*


Beiträge: 41
Registriert seit: Aug 2013

2014
-
DE


Deutschland
RE: VISA-Read-Fehler-1073807339
[/quote]
Aha, das VNA (welches eigentlich genau?) hat RJ45, am Ende sogar eine TCP/IP-Schnittstelle?
[/quote]

Ich habe ein VNA-Board. Dieses wird im Normalfall in einem Anritsu MS4640A verbaut, das halt auch noch weitere Anschlüsse hat. Ich probiere aber erstmal noch die TCP/IP Open.vi und gebe nochmal Rückmeldung.
Danke erstmal
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
30
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  CANopen VISA Read liefert unerwartete Antwort MarkusS 10 2.007 09.08.2019 12:31
Letzter Beitrag: GerdW

Gehe zu: