INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Probleme mit Stabilität eines Labview Programms



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

21.02.2012, 10:08
Beitrag #1

jojo2203 Offline
LVF-Gelegenheitsschreiber
**


Beiträge: 56
Registriert seit: Nov 2007

2011
2007
kA

09126
Deutschland
Probleme mit Stabilität eines Labview Programms
Hallo,

ich habe mir eine Labview Anwendung zur Steuerung einer elektronischen Last geschrieben, soweit habe ich jetzt alle Funktionen die ich brauche drin, wie Einstellung der Parameter, speichern in eine Datei und Anzeige in einem Chart. Ich könnte also glücklich und zufrieden sein, bin ich aber nicht weil das Programm nach einer scheinbar zufälligen Zeitspanne festgeht, sich also nicht mehr bedienen läßt und ich den kompletten Rechner neustarten muss. Ich habe nun schon auf das Speichern verzichtet, mir jede Menge Probepunkte eingerichtet, die Zyklenzeit von 1 auf 5 sec erhöht, um denm Problem auf die Spur zu kommen. Jetzt bin ich mit meinem Latein am Ende. Vielleicht kann jemand von den erfahreren Users mal kurz drübersehen und findet die Fehlerursache.

Danke. MfG jojo


Angehängte Datei(en)
11.0 .llb  anwendung elektronische last.llb (Größe: 488,09 KB / Downloads: 90)
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
21.02.2012, 18:25
Beitrag #2

eb Offline
LVF-Lernwilliger
***


Beiträge: 292
Registriert seit: Mar 2008

2014
2008
EN

12xxx
Deutschland
RE: Probleme mit Stabilität eines Labview Programms
Hallo jojo2203,

kann es sein, dass du in jedem Schleifendurchlauf dein VISA initialisierst, aber nicht wieder beendest?
Oder anders ausgedrückt: Warum initialisierst du immer und immer wieder deine Verbindung? Schließen tust du sie doch auch nur 1x.

Also ich würd versuchen, das ganze Initialisierungs-Gedöns vor die While-Schleife zu packen.
Zusätzlich waren evtll ein paar weitere SubVIs nicht schlecht um den (schon OK aufgeräumten) BD-Platz zu optimieren. (bspw.: SpeicherVI)


Gruß
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
21.02.2012, 22:08
Beitrag #3

GerdW Offline
______________
LVF-Team

Beiträge: 16.182
Registriert seit: May 2009

09SP1, 11SP1, 17 (selten 19)
1995
DE_EN

10×××
Deutschland
RE: Probleme mit Stabilität eines Labview Programms
Hallo jojo,

noch ein paar generelle Anmerkungen:
- es ist nicht sonderlich hilfreich, diversen subVIs das gleiche Icon zu verpassen
- es hat einen Sinn, wenn der Styleguide sagt, man solle ErrorIn/Out-Anschlüsse bei einem 4224-Connector unten links/rechts anschließen
- man muss beim IndexArray nicht zwingend eine Null (bzw. fortlaufende Indizes) vorgeben
- du brauchst in deinem VI keine Sequenzstrukturen (THINK DATAFLOW)
- es gibt Vergleichsfunktionen, die mit Null vergleichen
- wieso diese ganzen Rechenoperationen mit Arrays, die nur ein Element enthalten? Warum nicht gleich mit Skalaren rechnen?

Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  Probleme bei mehrmaliger Verwendung eines Sub-VI in Schleife BodenseeBike 2 1.518 01.03.2017 17:59
Letzter Beitrag: BodenseeBike
  Datenverlust in XY Graph beim automatischen Beenden des Programms Atlaspremier 6 2.057 24.08.2016 11:27
Letzter Beitrag: Freddy
  Öffnen eines Desktopfensters von Labview aus. RadioactiveMan 7 4.729 24.08.2015 12:24
Letzter Beitrag: tobi45f
  Absturzmeldung nach Beenden des Programms Tobi Wan Kenobi 6 1.852 10.02.2015 13:43
Letzter Beitrag: Tobi Wan Kenobi
  Unregelmäßiger Absturz beim Start des Programms blackrose1904 3 2.936 17.10.2014 08:52
Letzter Beitrag: GerdW
  Übertragen eines Programms auf Arduino anja210 1 3.265 31.07.2012 16:12
Letzter Beitrag: rolfk

Gehe zu: