INFO: Dieses Forum nutzt Cookies...
Cookies sind für den Betrieb des Forums unverzichtbar. Mit der Nutzung des Forums erklärst Du dich damit einverstanden, dass wir Cookies verwenden.

Es wird in jedem Fall ein Cookie gesetzt um diesen Hinweis nicht mehr zu erhalten. Desweiteren setzen wir Google Adsense und Google Analytics ein.


Antwort schreiben 

Erkennung und Ansprechen von Audio-Devices



Wenn dein Problem oder deine Frage geklärt worden ist, markiere den Beitrag als "Lösung",
indem du auf den "Lösung" Button rechts unter dem entsprechenden Beitrag klickst. Vielen Dank!

08.11.2017, 09:36
Beitrag #1

F.Bi Offline
LVF-Gelegenheitsschreiber
**


Beiträge: 152
Registriert seit: Oct 2007

LabView 2016
2007
EN

55218
Deutschland
Question Erkennung und Ansprechen von Audio-Devices
Guten Morgen,
ich habe Probleme mit der Erkennung bzw. dem Ansprechen von Audio-Devices.

Es sollen Wav-Dateien abgespielt werden und Ansagen über text to speech ertönen. Das hat bisher (festgelegt über Device 0) auch funktioniert, jetzt soll die Ausgabe wahlweise auch über Bluetooth-Lautsprecher stattfinden. Dazu kann der Anwender die Ausgabemöglichkeit auswählen.

Das Problem dabei ist aber, das irgendwie die Devicenummern für die Ausgabe der Wavedateien und Ansage über text to speech unterschiedlich sind, je nachdem wie die Devices ausgelesen bzw. erkannt werden.
Ich habe ein kleines Testprogramm erstellt und dazu auch mal einige Bilder angefertigt.

Bild AudioDev-1: Neustart
Bild AudioDev-2: Hörer (Jabra DIAL 550) angeschlossen
Bild AudioDev-3: LabVIEW mit angeschlossenem Hörer (Jabra DIAL 550) neu gestartet
Bild AudioDev-4: anderer PC mit optimaler Erkennung. Aber auch da gibt es die oben gezeigten Zustände.

               

Item Name wird von Get Audio Devices.vi zugewiesen.
Names wird über Get Num Devices.vi und Sound Device Info.vi (Get Audio Devices -V1.vi) zugewiesen.

Je nach Situation führen die beiden Wege zu unterschiedlichen Anzeigen (Bilder).

Ideal wäre es, wenn wie im Bild AudioDev-4 zu sehen, die Arrays identisch wären.
Wenn die Reihenfolge unterschiedlich ist (Bilder AudioDev-1 oder AudioDev-3), stellt das auch kein Problem dar, da ich ein ausgesuchtes Ausgabegerät im zweiten Array suchen kann und die entsprechenden Devicenummern an die Ausgabe-VIs leiten kann (Nicht im Beispiel enthalten).

Das Problem ist aber, wie im Bild AudioDev-2 zu sehen, die Devices nicht richtig über Get Num Devices.vi und Sound Device Info.vi (Names) erkannt werden, wenn ein Audiogerät angeschlossen bzw. entfernt und LabVIEW schon läuft und nicht neu gestartet wird.

Nach viel Erklärung (hoffentlich verständlich und nachvollziehbar) eine kurze Frage:

Wie kann ich die Audiodevices zuverlässig erkennen und den Ausgabe-VIs die passende Dev-Nummer übergeben?

Schon mal vielen Dank für die Hilfe...


Angehängte Datei(en)
0.0 .zip  Test Audio Device.zip (Größe: 97,39 KB / Downloads: 130)

Gruß
Frank
Alle Beiträge dieses Benutzers finden
Diese Nachricht in einer Antwort zitieren to top
Anzeige
Antwort schreiben 


Möglicherweise verwandte Themen...
Themen Verfasser Antworten Views Letzter Beitrag
  Steuerung Audio-Input/ Output BollerJan 0 4.093 07.04.2015 07:16
Letzter Beitrag: BollerJan
  Erkennung von mehreren Kreisen in einer JPG-Datei TiCy 6 4.823 21.03.2013 11:02
Letzter Beitrag: jg
  Audio Eingang verwenden? gottfried 6 5.958 25.05.2011 14:54
Letzter Beitrag: gottfried
  Audio CD lesen NDR 2 3.554 24.06.2007 12:48
Letzter Beitrag: Y-P
  Audio (nicht .wav) spielen NDR 4 3.552 07.05.2007 12:45
Letzter Beitrag: NDR
  Mediaplayer2 Erkennung von einem Dateiende florianBO 1 2.558 18.04.2007 12:16
Letzter Beitrag: Y-P

Gehe zu: